Bug 166142 - OHCI-1394 Crash in usb_hcd_irq results "Disabling IRQ #10"
OHCI-1394 Crash in usb_hcd_irq results "Disabling IRQ #10"
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
4
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-17 07:36 EDT by Ozan Eren BILGEN
Modified: 2015-01-04 17:21 EST (History)
2 users (show)

See Also:
Fixed In Version: kernel-2.6.13-1.1526_FC4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-05 16:15:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ozan Eren BILGEN 2005-08-17 07:36:12 EDT
Description of problem:

An USB related kernel module crashes on boot, kernel decides to disable IRQ #10.

ohci1394: $Rev: 1250 $ Ben Collins <bcollins@debian.org>
ohci1394: fw-host0: Unexpected PCI resource length of 1000!
ohci1394: fw-host0: OHCI-1394 1.0 (PCI): IRQ=[5] MMIO=[f8400000-f84007ff] Max
Packet=[2048]
irq 10: nobody cared!
[<c01517e4>] __report_bad_irq+0x24/0x7f
[<c01518b6>] note_interrupt+0x59/0x83
[<c0150b90>] __do_IRQ+0x1f7/0x347
[<c0105b1d>] do_IRQ+0x4a/0x82
=======================
[<c0138c45>] delayed_work_timer_fn+0x0/0xa
[<c0103c0e>] common_interrupt+0x1a/0x20
[<c01282bc>] __do_softirq+0x2c/0x8a
[<c0105c29>] do_softirq+0x3e/0x42
=======================
[<c0105b24>] do_IRQ+0x51/0x82
[<c0103c0e>] common_interrupt+0x1a/0x20
[<e013136e>] set_phy_reg+0xe1/0x270 [ohci1394]
[<c0156e9b>] __free_pages_ok+0x9d/0xc4
[<e0132843>] ohci_devctl+0x605/0xaf6 [ohci1394]
[<e018bc33>] csr1212_fill_cache+0xdf/0x106 [ieee1394]
[<e018bda1>] csr1212_generate_csr_image+0x147/0x23e [ieee1394]
[<e0181133>] hpsb_reset_bus+0x20/0x26 [ieee1394]
[<c0138e52>] worker_thread+0x198/0x457
[<c03705ad>] schedule+0x31d/0x7b3
[<c011be46>] __wake_up_common+0x39/0x59
[<e0183bd0>] delayed_reset_bus+0x0/0xc0 [ieee1394]
[<c011be01>] default_wake_function+0x0/0xc
[<c0138cba>] worker_thread+0x0/0x457
[<c013f57b>] kthread+0x87/0x8b
[<c013f4f4>] kthread+0x0/0x8b
[<c01012ad>] kernel_thread_helper+0x5/0xb
handlers:
[<c02d181e>] (usb_hcd_irq+0x0/0x52)
[<c02d181e>] (usb_hcd_irq+0x0/0x52)
Disabling IRQ #10

And some lspci -v output here, if you like:

00:1d.0 USB Controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB UHCI
Controller #1 (rev 02) (prog-if 00 [UHCI])
Subsystem: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB UHCI Controller #1
Flags: bus master, medium devsel, latency 0, IRQ 10
I/O ports at e000 [size=32]

00:1d.1 USB Controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB UHCI
Controller #2 (rev 02) (prog-if 00 [UHCI])
Subsystem: Intel Corporation: Unknown device 24d2
Flags: bus master, medium devsel, latency 0, IRQ 5
I/O ports at e100 [size=32]

00:1d.2 USB Controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB UHCI #3
(rev 02) (prog-if 00 [UHCI])
Subsystem: Intel Corporation: Unknown device 24d2
Flags: bus master, medium devsel, latency 0, IRQ 3
I/O ports at e200 [size=32]

00:1d.3 USB Controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB UHCI
Controller #4 (rev 02) (prog-if 00 [UHCI])
Subsystem: Intel Corporation: Unknown device 24d2
Flags: bus master, medium devsel, latency 0, IRQ 10
I/O ports at e300 [size=32]

00:1d.7 USB Controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB2 EHCI
Controller (rev 02) (prog-if 20 [EHCI])
Subsystem: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB2 EHCI Controller
Flags: bus master, medium devsel, latency 0, IRQ 7
Memory at f8580000 (32-bit, non-prefetchable) [size=1K]
Capabilities: [50] Power Management version 2

/proc/interrupts output. Interrupt counters in the lines with usbX does not
change when I launch an application, which uses an USB device (webcam+xawtv). 

CPU0
0: 1263542 XT-PIC timer
1: 5129 XT-PIC i8042
2: 0 XT-PIC cascade
3: 0 XT-PIC uhci_hcd:usb4
5: 0 XT-PIC uhci_hcd:usb3, ohci1394
7: 2 XT-PIC ehci_hcd:usb1
8: 1 XT-PIC rtc
10: 100000 XT-PIC uhci_hcd:usb2, uhci_hcd:usb5
11: 6520 XT-PIC eth0
12: 59282 XT-PIC i8042
14: 9672 XT-PIC ide0
NMI: 0
ERR: 0

I tried to turn off ACPI in BIOS configuration and added acpi=off and noacpi to
boot parameters. When I disable on-board USB in BIOS, i don't get a crash
message, but obviously i cannot use the USB sockets. I upgraded my kernel with
kernel-2.6.12-1.1398_FC4.i686.rpm package but it didn't help either. Later, I
compiled kernel-2.6.12.4 from the sources distibuted by kernel.org, still not
worked. When I saw that Mandriva Limited Edition 2005 has no problems with the
bridge, I tried to compile the kernel with its config file, too; but I cannot
solve the problem. I also removed modprobe.conf and hwscan before running kudzu
--it didn't help...

The computer I am using is a small black box. I use the same chipset in my
desktop computer, where I installed FC4, and I am happy with the camera. I
changed the HDD of the black box, put it into a clone of this box, but the
problem occures again.


Version-Release number of selected component (if applicable):
kernel-2.6.11-1.1369_FC4
kernel-2.6.12-1.1398_FC4


How reproducible:
Always


Steps to Reproduce:
1. Boot the computer
2. Init displays:
Initializing hardware... storage network audio done  [ OK ]
Disabling IRQ #10
  

Actual results:
USB devices don't work correctly, for example I cannot use my webcam. Sometimes
it blocks Ethernet too (e100 driver crashes).


Expected results:
USB host should work correctly, 10th IRQ should be up and running.


Additional info:
N/A
Comment 1 Ozan Eren BILGEN 2005-08-29 04:49:30 EDT
Hi,

I found a quick & dirty solution against the problem. It is very miserable so
that it cannot be published as a workaround but still I want to share it with
you, because I think it will help you to find the problem's root.

# rm -Rf /lib/modules/$(uname -r)/kernel/drivers/ieee1394
# depmod -a
# rm -Rf \
/etc/hotplug/{firmware.agent,ieee1394.agent,dasd.agent,pci*,scsi.agent,tape.agent}

Probably, most of the remove operations in /etc/hotplug is not necessary. One
has to try which one is causing the problem. It is certain that the kernel
crashes when the ieee1394 driver is loaded (I don't mean that the driver is
broken!) and the easiest way is to remove the folder, because I don't use such
kind of devices. In short, after this massacre, both USB and Ethernet works
perfectly (They got their lesson :-P).

Now I can say that the problem seems to be related to hotplug & ieee1394.
Finally, I have to add that in crashed kernel's stack report, sometimes I saw
function names related to e100 or ieee1394 driver, but at the end I always met
with usb_hcd_irq.


Have a nice day.
Comment 2 Dave Jones 2005-09-30 02:22:45 EDT
Mass update to all FC4 bugs:

An update has been released (2.6.13-1.1526_FC4) which rebases to a new upstream
kernel (2.6.13.2). As there were ~3500 changes upstream between this and the
previous kernel, it's possible your bug has been fixed already.

Please retest with this update, and update this bug if necessary.

Thanks.
Comment 3 Ozan Eren BILGEN 2005-10-05 16:15:05 EDT
Good guess! ;-)

The kernel still crashes, but now dmesg output prints an useful hint something
like "append irqpoll to kernel parameters". I listened the suggestion, rolled
back all the changes to the original FC4 configuration and now I am happy.

OK, it seems to be fixed. Thanks everybody!..


Ozan Eren Bilgen

Note You need to log in before you can comment on or make changes to this bug.