This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 166157 - Missing HelixPlayer and openoffice.org sub-packages in x86_64 distro
Missing HelixPlayer and openoffice.org sub-packages in x86_64 distro
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: comps (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Elliot Lee
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-17 12:11 EDT by Alexandre Oliva
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-04 11:52:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexandre Oliva 2005-08-17 12:11:31 EDT
Is it intentional that HelixPlayer is not included in the x86_64 devel tree? 
How about the following OOo sub-packages:

./openoffice.org-base-1.9.124-1.2.0.fc5.i386.rpm
./openoffice.org-emailmerge-1.9.124-1.2.0.fc5.i386.rpm
./openoffice.org-langpack-bn_IN-1.9.124-1.2.0.fc5.i386.rpm
./openoffice.org-langpack-hr_HR-1.9.124-1.2.0.fc5.i386.rpm
./openoffice.org-langpack-pa_IN-1.9.124-1.2.0.fc5.i386.rpm
./openoffice.org-pyuno-1.9.124-1.2.0.fc5.i386.rpm
Comment 1 Bill Nottingham 2005-08-19 03:07:19 EDT
HelixPlayer doesn't build on x86_64, so, yes.

pyuno can't work, it requires a 32-bit python. emailmerge requires pyuno, ergo...

What's OOo-base for?

The langpacks need fixed, yes.
Comment 2 Alexandre Oliva 2005-08-19 10:55:21 EDT
Couldn't the 32-bit HelixPlayer be included, if the 64-bit one doesn't build?
Comment 3 Caolan McNamara 2005-08-22 04:11:43 EDT
"ooo-base" is the openoffice.org hsqldb database access-like front-end, this
subpackage is a bit of a fake as it's only .desktop files and menu integration
because the database is always actually required, but both our UI guys and
upstream want it to look seperateable installable to not confuse
non-explicitly-desiring-database-users.
Comment 4 Alexandre Oliva 2005-10-27 10:10:39 EDT
This still applies to current development tree, but the OOo files missing in the
x86_64 distro are now different.  Here's a list:

./openoffice.org-base-2.0.0-3.6.2.i386.rpm
./openoffice.org-emailmerge-2.0.0-3.6.2.i386.rpm
./openoffice.org-langpack-bn_IN-2.0.0-3.6.2.i386.rpm
./openoffice.org-langpack-ga_IE-2.0.0-3.6.2.i386.rpm
./openoffice.org-langpack-hr_HR-2.0.0-3.6.2.i386.rpm
./openoffice.org-langpack-pa_IN-2.0.0-3.6.2.i386.rpm
./openoffice.org-pyuno-2.0.0-3.6.2.i386.rpm

It's the langpacks absence that I'm most concerned with, as I understand the
others are intentionally left out (except for -base; I can't tell from the
previous comment why one wouldn't want it on x86_64)
Comment 5 Caolan McNamara 2005-10-27 10:23:20 EDT
I believe the langpacks are done now, pyuno and emailmerge won't be done as they
require a 32bit python.
Comment 6 Bill Nottingham 2005-10-27 13:12:41 EDT
Well, for updates it requires tweaking the update system. For the devel tree and
core releases, it requires tweaking the comps file. Yes, this is a mess.
Comment 7 Alexandre Oliva 2005-10-29 17:57:59 EDT
langpacks and base are still missing from the x86_64 tree in today's development
tree.
Comment 8 Need Real Name 2005-11-02 09:13:22 EST
Can this bug be restated as "x86_64 specific OOo packages are not available?"  I
notice in FC4 updates for x86_64 that all the OOo packages are i386
architecture.  That is a bug, correct?
Comment 9 Alexandre Oliva 2005-11-03 11:19:33 EST
No, this is not about OOo packages being 32-bit on AMD64, this is about some of
the translations and other sub-packages not being listed in the comps files,
which would get them distributed as part of the AMD64 distribution.  It would be
nice if this error was fixed in time for FC5test1.
Comment 10 Bill Nottingham 2005-11-03 12:30:47 EST
Done, should show up tomorrow.
Comment 11 Alexandre Oliva 2005-11-04 09:07:19 EST
OOo translations and base are in today's x86_64 compose, confirmed.  HelixPlayer
is still missing, though.  Is that on purpose?
Comment 12 Bill Nottingham 2005-11-04 11:52:43 EST
Aha, dug out the reason. Helix is x86 only because it pulls in browser packages
for i386 if it is installed multilib. Hence, Helix is WONTFIX, but closing as
RAWHIDE for the OO.o stuff.

Note You need to log in before you can comment on or make changes to this bug.