Bug 166162 - firefox-1.1-0.2.6.deerpark.alpha2 won't start
firefox-1.1-0.2.6.deerpark.alpha2 won't start
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Aillon
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-17 14:09 EDT by Tom London
Modified: 2007-11-30 17:11 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-20 07:07:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
output of 'strace /usr/bin/firefox' (34.02 KB, text/plain)
2005-08-17 14:10 EDT, Tom London
no flags Details

  None (edit)
Description Tom London 2005-08-17 14:09:17 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.11) Gecko/20050815 Fedora/1.7.11-2

Description of problem:
After today's updates, firefox fails to start for me.  

I'm running latest rawhide, targetted/enforcing, but this fails in both enforcing and permissive modes (and no messages in audit.log or messages).

I also tried getting rid of my .mozilla directory to no avail.

I installed the 'new' cairo package (so I have both cairo-0.6.0-2 and cairo-0.9.2-2 installed).

Mozilla runs fine.

output of 'strace /usr/bin/firefox' attached.....

Version-Release number of selected component (if applicable):
firefox-1.1-0.2.6.deerpark.alpha2

How reproducible:
Always

Steps to Reproduce:
1. Try to start firefox
2.
3.
  

Additional info:
Comment 1 Tom London 2005-08-17 14:10:30 EDT
Created attachment 117853 [details]
output of 'strace /usr/bin/firefox'
Comment 2 Dennis Jacobfeuerborn 2005-08-17 14:18:36 EDT
I can confirm the problem. Executing

LD_LIBRARY_PATH=/usr/lib/firefox-1.1 ./firefox-bin

results in the following error:

./firefox-bin: symbol lookup error:
/usr/lib/firefox-1.1/components/libgfx_gtk.so: undefined symbol:
pango_xft_get_font_map
Comment 3 Sammy 2005-08-17 14:41:21 EDT
Yes. I fixed this for 1.0.6 on rawhide using the latest cairo/pango. Some reason this   
particular so is not linking with libpangoxft. Something with pkgconfig. I added  to  
one of /usr/lib/gdk-2.0.pc or /usr/lib/gdk-x11-2.0.pc the Requirement for  pangoxft 
and recompiled. 
 
Something needs to be fixed in these dependencies. 
Comment 4 Rahul Sundaram 2005-08-17 14:48:43 EDT
Able to reproduce this.changing status to assigned
Comment 5 Steven Usdansky 2005-08-18 17:20:52 EDT
Same problem. I downloaded
/pub/mozilla.org/firefox/releases/deerpark/alpha2/linux-i686/en-US/deerpark-alpha2.tar.gz
 which does work
Comment 6 Sylvain Rouillard 2005-08-19 02:15:53 EDT
Confirmed on my x86_64 box too. 
 
[sal@localhost ~]$ /usr/lib64/firefox-1.1/firefox-bin 
/usr/lib64/firefox-1.1/firefox-bin: error while loading shared libraries: 
libmozjs.so: cannot open shared object file: No such file or directory 
[sal@localhost ~]$ locate libmozjs 
/usr/local/firefox/libmozjs.so 
/usr/lib64/firefox-1.1/libmozjs.so 
Comment 7 Seika van Olstroem 2005-08-19 05:14:22 EDT
Confirmed on my x86 box.

Starting firefox with this commandline works for me:
LD_LIBRARY_PATH=/usr/lib/firefox-1.1 MOZ_DISABLE_PANGO=1 firefox
Comment 8 Sylvain Rouillard 2005-08-19 07:57:44 EDT
Fixed for me with today's update (0.2.7).
Txs
Comment 9 Dennis Jacobfeuerborn 2005-08-19 09:37:58 EDT
The latest update fixed this for me too. Thanks!
Comment 10 Rahul Sundaram 2005-08-20 07:07:12 EDT
Thanks for the bug report. This particular bug was fixed and a update package
was published for download. Please feel free to report any further bugs you find.

Note You need to log in before you can comment on or make changes to this bug.