Bug 1661684 - aircrack-ng file conflicts with filesystem
Summary: aircrack-ng file conflicts with filesystem
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: aircrack-ng
Version: rawhide
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Ivan Chavero
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-12-22 04:32 UTC by George R. Goffe
Modified: 2019-01-22 18:29 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-01-22 18:29:31 UTC


Attachments (Terms of Use)

Description George R. Goffe 2018-12-22 04:32:18 UTC
Description of problem: Attempting to upgrade this system produced file conflicts with filesystem package (see below)


Version-Release number of selected component (if applicable):
see below

How reproducible:
always

Steps to Reproduce:
1.see below
2.
3.

Actual results:
see below

Expected results:
clean and successful system upgrade

Additional info:

/usr/bin/dnf --refresh --skip-broken upgrade
Fedora - Modular Rawhide - Developmental packages for the next Fedora release                                 12 kB/s |  15 kB     00:01
Fedora - Rawhide - Developmental packages for the next Fedora release                                        2.1 kB/s |  15 kB     00:07
Dependencies resolved.
=============================================================================================================================================
 Package                            Arch                          Version                               Repository                      Size
=============================================================================================================================================
Upgrading:
 aircrack-ng                        x86_64                        1.5.2-2.fc30                          rawhide                        4.7 M

Transaction Summary
=============================================================================================================================================
Upgrade  1 Package

Total download size: 4.7 M
Is this ok [y/N]: y
Downloading Packages:
aircrack-ng-1.5.2-2.fc30.x86_64.rpm                                                                          410 kB/s | 4.7 MB     00:11
---------------------------------------------------------------------------------------------------------------------------------------------
Total                                                                                                        359 kB/s | 4.7 MB     00:13 
Running transaction check
Transaction check succeeded.
Running transaction test
The downloaded packages were saved in cache until the next successful transaction.
You can remove cached packages by executing 'dnf clean packages'.
Error: Transaction check error:
  file /usr/lib from install of aircrack-ng-1.5.2-2.fc30.x86_64 conflicts with file from package filesystem-3.9-2.fc29.x86_64
  file /usr/lib64 from install of aircrack-ng-1.5.2-2.fc30.x86_64 conflicts with file from package filesystem-3.9-2.fc29.x86_64
  file /usr/sbin from install of aircrack-ng-1.5.2-2.fc30.x86_64 conflicts with file from package filesystem-3.9-2.fc29.x86_64

Error Summary
-------------

Comment 1 Ivan Chavero 2018-12-24 22:36:29 UTC
Reproduced successfully in rawhide, fixing

Comment 2 George R. Goffe 2019-01-03 21:56:42 UTC
Ivan,

Has this bug been fixed yet? I don't see anything on the repos.

Thanks for your help!

George...

Comment 3 Chatty 2019-01-07 23:05:22 UTC
Just updated FC30 and tried to install aircrack-ng afterwards. Still same error message as above.

Comment 4 George R. Goffe 2019-01-08 22:17:57 UTC
Chatty,

I'm not an rpm guru so this might be a stupid question. Please have patience.

If I understand rpms in general, this problem seems to be related to "ownership" of the directories above. Does it make sense that ANY rpm "owns" these directories? Shouldn't the concept of "ownership" be ONLY related to files/directories that are specific to an rpm? Maybe you "guys" have done this already with the "filesystem" rpm? If so, then all others should "rent" these directories rather than try to "own" them? Perhaps establishing a phantom rpm named "system" to "own" files/directories like these 3?

Just my thoughts.

Best regards,

George...

Comment 5 Ivan Chavero 2019-01-22 18:29:31 UTC
I've built a new package that fixes this error:

Rawhide: https://koji.fedoraproject.org/koji/buildinfo?buildID=1181520
F29: https://koji.fedoraproject.org/koji/buildinfo?buildID=1181523
F28: https://koji.fedoraproject.org/koji/buildinfo?buildID=1181524

Feel free to reopen this bug if the problem persits.


Note You need to log in before you can comment on or make changes to this bug.