Bug 1661735 - SELinux is preventing abrt-handle-eve from 'write' accesses on the directory oops-2018-12-20-21:31:39-1093-0.
Summary: SELinux is preventing abrt-handle-eve from 'write' accesses on the directory ...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: rawhide
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Zdenek Pytela
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:3c55e7c363985c37225b0eea911...
: 1661736 1661737 1661738 1661739 1661740 1661741 1661834 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-12-22 19:18 UTC by Mikhail
Modified: 2018-12-25 11:03 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-12-25 10:56:46 UTC
Type: ---


Attachments (Terms of Use)

Description Mikhail 2018-12-22 19:18:48 UTC
Description of problem:
SELinux is preventing abrt-handle-eve from 'write' accesses on the directory oops-2018-12-20-21:31:39-1093-0.

*****  Plugin catchall (100. confidence) suggests   **************************

If you believe that abrt-handle-eve should be allowed write access on the oops-2018-12-20-21:31:39-1093-0 directory by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# ausearch -c 'abrt-handle-eve' --raw | audit2allow -M my-abrthandleeve
# semodule -X 300 -i my-abrthandleeve.pp

Additional Information:
Source Context                system_u:system_r:abrt_t:s0-s0:c0.c1023
Target Context                system_u:object_r:unlabeled_t:s0
Target Objects                oops-2018-12-20-21:31:39-1093-0 [ dir ]
Source                        abrt-handle-eve
Source Path                   abrt-handle-eve
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           
Target RPM Packages           
Policy RPM                    selinux-policy-3.14.3-15.fc30.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Host Name                     (removed)
Platform                      Linux (removed) 4.20.0-0.rc7.git1.1.fc30.x86_64 #1
                              SMP Tue Dec 18 22:52:01 UTC 2018 x86_64 x86_64
Alert Count                   1
First Seen                    2018-12-23 00:17:11 +05
Last Seen                     2018-12-23 00:17:11 +05
Local ID                      ad72d0ee-9774-41a4-824d-55f5625c3c69

Raw Audit Messages
type=AVC msg=audit(1545506231.484:372): avc:  denied  { write } for  pid=15230 comm="abrt-handle-eve" name="oops-2018-12-20-21:31:39-1093-0" dev="nvme0n1p2" ino=3283306 scontext=system_u:system_r:abrt_t:s0-s0:c0.c1023 tcontext=system_u:object_r:unlabeled_t:s0 tclass=dir permissive=1


Hash: abrt-handle-eve,abrt_t,unlabeled_t,dir,write

Version-Release number of selected component:
selinux-policy-3.14.3-15.fc30.noarch

Additional info:
component:      selinux-policy
reporter:       libreport-2.9.7
hashmarkername: setroubleshoot
kernel:         4.20.0-0.rc7.git1.1.fc30.x86_64
type:           libreport

Comment 1 Zdenek Pytela 2018-12-25 10:56:46 UTC
Hi,

It looks like the directory in the report has incorrect label. You can fix it with a command like this:

  # restorecon -Rv /var/spool/abrt

provided abrt uses the default directory, or adjust the restorecon argument if the directory is different - note the report contains only directory name, not the full path.

Alternatively, you can also relabel all filesystems:

  # fixfiles onboot

and reboot the system.

Closing as NOTABUG. Feel free to reopen the bugzilla if the issue persists.

Comment 2 Zdenek Pytela 2018-12-25 10:59:07 UTC
*** Bug 1661736 has been marked as a duplicate of this bug. ***

Comment 3 Zdenek Pytela 2018-12-25 10:59:42 UTC
*** Bug 1661737 has been marked as a duplicate of this bug. ***

Comment 4 Zdenek Pytela 2018-12-25 11:00:34 UTC
*** Bug 1661738 has been marked as a duplicate of this bug. ***

Comment 5 Zdenek Pytela 2018-12-25 11:00:55 UTC
*** Bug 1661739 has been marked as a duplicate of this bug. ***

Comment 6 Zdenek Pytela 2018-12-25 11:02:35 UTC
*** Bug 1661740 has been marked as a duplicate of this bug. ***

Comment 7 Zdenek Pytela 2018-12-25 11:02:55 UTC
*** Bug 1661741 has been marked as a duplicate of this bug. ***

Comment 8 Zdenek Pytela 2018-12-25 11:03:42 UTC
*** Bug 1661834 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.