Bug 166179 - fixfiles may run find across /home nfs dirs, hanging policy rebuild
fixfiles may run find across /home nfs dirs, hanging policy rebuild
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: policycoreutils (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Walsh
Ben Levenson
:
Depends On:
Blocks: 156322
  Show dependency treegraph
 
Reported: 2005-08-17 16:06 EDT by Jon Orris
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version: RHBA-2005-645
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-05 12:35:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jon Orris 2005-08-17 16:06:09 EDT
Description of problem:
Discovered testing targeted policy updates when rpm transaction appeard to hang.
 The cause was a find call in fixfiles running over very large nfs directories
mounted off /home. The list of directories to search is created at line 63 in
fixfiles:

/usr/bin/diff $PREFC $FC | grep '^[<>]'|cut -c3-| grep ^/ | \
	sed -r -e 's,[[:blank:]].*,,g' \
               -e 's|\(([/[:alnum:]]+)\)\?|{\1,}|g' \

This will include /home directories, which the targeted policy should not be
touching on update in any case. If /home includes large nfs dirs, this will
cause fixfiles to run for a very long time, possibly several hours.

Dan proposed adding an exclusion for /home, as follows:

/usr/bin/diff $PREFC $FC | grep '^[<>]'|cut -c3-| grep ^/ | grep -v ^/home | \
	sed -r -e 's,[[:blank:]].*,,g' \
	    -e 's|\(([/[:alnum:]]+)\)\?|{\1,}|g' \
Comment 7 Daniel Walsh 2005-08-19 14:07:34 EDT
Fixed in policycoreutils-1.18.1-4.5
Comment 8 Red Hat Bugzilla 2005-10-05 12:35:00 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2005-645.html

Note You need to log in before you can comment on or make changes to this bug.