Bug 166216 - svn crashes when adding in working copy entire directory with files
svn crashes when adding in working copy entire directory with files
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: subversion (Show other bugs)
4
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Joe Orton
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-17 17:34 EDT by Michal Piotrowski
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: 1.2.3-2.1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-12 08:51:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Core dump (748.00 KB, application/octet-stream)
2005-08-18 03:42 EDT, Michal Piotrowski
no flags Details

  None (edit)
Description Michal Piotrowski 2005-08-17 17:34:49 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; pl-PL; rv:1.7.10) Gecko/20050720 Fedora/1.0.6-1.1.fc4 Firefox/1.0.6

Description of problem:
If create new directory in your working copy, add some files to it and issue 'svn add' on this directory svn causes segmentation fault.

Version-Release number of selected component (if applicable):
1.2.1-2.1

How reproducible:
Always

Steps to Reproduce:
1. Checkout some repository
2. Create new subdirectory in working copy
3. Add file(s) to this subdirectory
4. Issue: svn add path/to/new/dir
  

Actual Results:  svn starts to add files in this dir then causes segmentation fault. This directory is marked as locked and you have to issue svn cleanup to enable further usage of your working directory.

Expected Results:  'svn add' should be performed without any problems.

Additional info:

Nothing is lost and after you issue 'svn cleanup' you can work. But it is irritating.
Comment 1 Joe Orton 2005-08-18 01:49:37 EDT
Do you have an exact reproduction recipe for this?  Can you get a core dump from
the crash?

(run "ulimit -c unlimited" then reproduce the issue)
Comment 2 Michal Piotrowski 2005-08-18 03:40:55 EDT
I tested this again. And I noticed that core dump only happens when my locale is
set to Polish (LANG=pl_PL.UTF-8), which is my default. It doesn't happen when I
temporarily switched to LANG=C. Here is the sequece of test commands:
mkdir repo
mkdir work
svnadmin create repo/svn-repo
mkdir work/trunk
svn import work file:///home/test/tmp/svn/repo/svn-repo/
rm -rf work/*
svn co file:///home/test/tmp/svn/repo/svn-repo/ work
mkdir work/trunk/new_dir
touch work/trunk/new_dir/new_file
svn add work/trunk/new_dir
---
Result:
A         work/trunk/new_dir
A         work/trunk/new_dir/new_file
Naruszenie ochrony pamięci (core dumped)

I will attach dumped core as attachment.
Comment 3 Michal Piotrowski 2005-08-18 03:42:41 EDT
Created attachment 117863 [details]
Core dump
Comment 4 Joe Orton 2005-08-18 04:19:40 EDT
Thanks.  It looks like a mis-translated format string - it appears to be fixed
upstream for the forthcoming 1.2.2 release.
Comment 5 Joe Orton 2005-08-30 06:53:48 EDT
Please try the 1.2.3 packages in testing:

yum --enablerepo=updates-testing update subversion
Comment 6 Michal Piotrowski 2005-09-01 04:36:38 EDT
I have just got back from my holidays, checked this new version and it works for
me. No core dump.
Comment 7 Fedora Update System 2005-09-06 01:38:11 EDT
From User-Agent: XML-RPC

subversion-1.2.3-2.1 has been pushed for FC4, which should resolve this issue.

If these issues are still present in this version, then please re-open this bug.
Comment 8 Joe Orton 2005-10-12 08:51:06 EDT
Thanks for testing it out.

Note You need to log in before you can comment on or make changes to this bug.