Bug 166224 - emacs-auctex for FC3 conflicts with Core's emacspeak
emacs-auctex for FC3 conflicts with Core's emacspeak
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: emacs-auctex (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ed Hill
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-17 21:04 EDT by Alexandre Oliva
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-18 13:56:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexandre Oliva 2005-08-17 21:04:48 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.8b3) Gecko/20050815 Fedora/1.1-0.2.6.deerpark.alpha2 Firefox/1.0+

Description of problem:
An `everything' install of FC3 can't get emacs-auctex from extras installed, because it conflicts with emacspeak from Core.  Is such a conflict absolutely necessary?  I.e., do we need to upgrade emacspeak in FC3 up from 17.0, or is it just a matter of relaxing the conflict?

Version-Release number of selected component (if applicable):
emacs-auctex-11.55-4.fc3

How reproducible:
Always

Steps to Reproduce:
1.Install emacspeak from core
2.Try to install emacs-auctex from extras

Actual Results:  emacs-auctex won't go in because it conflicts with emacspeak < 18

Expected Results:  It should ideally be possible to install all packages from extras along with all packages from core

Additional info:
Comment 1 Ed Hill 2005-08-17 22:29:10 EDT
Hi Alexandre, I'll get in touch with the upstream auctex maintainers 
and try to find out why they have advertised incompatibility with 
emacspeak < 18.  
Comment 2 Ed Hill 2005-08-18 13:56:05 EDT
The upstream auctex maintainer (David Kastrup) informed me that emacspeak 
0.17 is more then three years old, that it "contains a completely buggy 
regexp-opt.el file" and that it has caused serious problems (crashes) for 
auctex users.  So, I'm going to follow his wishes and leave the current 
"Conflicts:" line in the emacs-auctex specfile as-is.

If the Core maintainers upgrade emacspeak, then the problem goes away.  
And, if not, people using FC-3 can just choose to have one or the other.  
Or they can upgrade to FC-4 and get both.  :-)

In the future, I'll be more careful to avoid adding packages to Extras 
that conflict with anything in Core.  But in this case, I don't see how 
it does any real harm offering an entirely *optional* package.
Comment 3 Alexandre Oliva 2005-08-18 15:03:47 EDT
For the record...  The harm it caused to the network I run is that we had a
perfectly functional yet ancient auctex-emacs package from Bero, that your
package attempts to update, but because of the conflict, causes the FC3 boxes to
not get any further updates without manual intervention.

Anyhow, thanks for the explanation, and for taking up the task of maintaining
this package that's very useful to myself and several other users at the
university in the lab I run.

Fortunately FC3 is just a dual-boot option on all of the boxes there, and pretty
much everybody has switched to FC4 already, so it's not really a big deal to me.
Comment 4 Ed Hill 2005-08-18 16:36:32 EDT
Hi Alexandre, I'm very sorry for the trouble this caused you.  I can see 
now (in hindsight) how having a pre-existing auctex package produces an 
unresovable dependency.  Rats...

And again, I'll be careful not to repeat this mistake.

Note You need to log in before you can comment on or make changes to this bug.