Bug 166225 - no Job ID was provided
no Job ID was provided
Status: CLOSED RAWHIDE
Product: Fedora Infrastructure
Classification: Retired
Component: extras buildsys (Show other bugs)
unspecified
All Linux
medium Severity medium
: ---
: ---
Assigned To: Seth Vidal
Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-17 21:13 EDT by Ralf Corsepius
Modified: 2007-04-18 13:30 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-18 21:45:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ralf Corsepius 2005-08-17 21:13:49 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050719 Fedora/1.7.10-1.5.1

Description of problem:
# make plague
/usr/bin/plague-client build perl-Sort-Versions perl-Sort-Versions-1_5-3_fc4 fc4
Package perl-Sort-Versions enqueued.  (However, no Job ID was provided in the time required)


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. make plague

  

Actual Results:  see above.

Additional info:
Comment 1 Zing 2005-08-18 00:25:33 EDT
this just happened to me:

make plague
/usr/bin/plague-client build perl-XML-LibXSLT perl-XML-LibXSLT-1_58-1_fc5 devel
Package perl-XML-LibXSLT enqueued.  (However, no Job ID was provided in the time
required)

I waited about an hour then tried again and the package was successfully
enqueued & returned a job id.
Comment 2 Dan Williams 2005-08-19 15:01:06 EDT
If the server is under heavy load at the time, or takes too long to enqueue the
job (currently 3 seconds) it won't pass the ID back to the client.  Its still
queued and you can find the job in the Web interface though.  This won't really
be fixed without larger changes to the codebase, so marking WONTFIX as it
doesn't really affect functionality, just presentation.
Comment 3 Ralf Corsepius 2005-08-19 18:47:56 EDT
(In reply to comment #2)
> If the server is under heavy load at the time, or takes too long to enqueue the
> job (currently 3 seconds) it won't pass the ID back to the client.
I guess, are you referring to times in a local network?

>  Its still
> queued and you can find the job in the Web interface though.
What you say doesn't match with my observations: At the time this had happened,
the job could NOT be found with "plague-client list".

Actually, I had invoked "make plague" ca. 10 times, but not a single job had
been queued. It's just just that invoking "make plague" a new several hours
laters, had succeeded.
Comment 4 Michael Schwendt 2005-08-19 19:13:09 EDT
Also see the detailed experience report in comment 1 and notice that
there's only a single job for perl-XML-LibXSLT-1_58-1_fc5 listed in
the web interface (job 126). So the build system did not enqueue the
first request, but only the second one an hour later.
Comment 5 Ralf Corsepius 2005-08-19 19:38:40 EDT
Reopening, because comment #2 apparently is not correct.

Wrt. to timeouts, I am on a DSL line, being connected to the buildsystem via a
transatlantic connection. I.e. if comment #2 should refer to internet
connections, 3 second timeouts probably is at least one magnitude too small.
Comment 6 Zing 2005-08-20 11:25:37 EDT
Just to confirm, comment #4 is correct, i didn't see my job listed in the web
interface that first time, only the second time.

I'm on a cable modem on the east coast
Comment 7 Dan Williams 2005-11-18 21:45:51 EST
Closing, this is a transient error and should usually be fixed with a
buildsystem kick when the build system is acting up.

Note You need to log in before you can comment on or make changes to this bug.