Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be unavailable on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1662262 - Doesn't display "Retype Admin User Password" box while provisioning instance in web console
Summary: Doesn't display "Retype Admin User Password" box while provisioning instance ...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.1.0
Assignee: Samuel Padgett
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-12-27 08:54 UTC by Zhang Cheng
Modified: 2019-03-12 14:27 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-02-06 20:11:09 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Zhang Cheng 2018-12-27 08:54:35 UTC
Description of problem: 
Provision a example apb from web console, found none "Retype Admin User Password" box, such as only have "Mediawiki Admin User Password" box. In another word, user only input password one time and cannot retype the password. Btw, same problem is existing in all four example apbs.


Version-Release number of selected component (if applicable):
oc v4.0.0-alpha.0+23c8cff-810
asbd 1.3.20
docker.io/automationbroker/automation-broker-operator:latest
docker.io/ansibleplaybookbundle/origin-ansible-service-broker:canary


How reproducible:
Always


Steps to Reproduce:
1. Config asb to aws registry and using apb images with 4.0 tag, and redeploy asb pod. 

2. Create service instance from web console.

3. Check parameter in create service instance page."Retype Admin User Password" box


Actual results: 
3. Not found "Retype Admin User Password" box in console.


Expected results: 
3. "Retype Admin User Password" box should be displayed in console.


addition info: 
Same problem is existing in all four example apbs.

Comment 2 Derek Whatley 2019-01-07 21:48:05 UTC
I believe this is an issue with the new "Developer Catalog" in the OpenShift 4.0 Console not respecting the `display_type: password` property that we are setting on the `mediawiki_admin_pass` parameter in our apb.yml, which eventually ends up in the clusterserviceplan OpenShift resource.

`display_type: password` specified in apb.yml:
https://github.com/ansibleplaybookbundle/mediawiki-apb/blob/master/apb.yml#L47-L51


`type: password` specified for `key: mediawiki_admin_pass`
https://gist.github.com/djwhatle/224ab1cbb0575c3b69fdf1731f0df9c7#file-mediawiki-clusterserviceplan-L31-L40

Comment 3 Samuel Padgett 2019-02-06 20:11:09 UTC
The 4.0 console is a separate code base from 3.11. While it has most of the same features and many new features, it doesn't have one-for-one feature parity with the previous 3.11 console. This is one of the features that we have not ported.

This particular request is difficult to implement since react-jsonschema-form does not let us do custom validation for custom fields, so there is no clean way to check that both passwords entered were the same. Given that this is problematic to implement and does not block users from creating the service instance, we do not plan to change the behavior. Note that it is possible to see the password in the parameters secret. If you do happen to mistype the password, it's possible to see the actual value, so you're not locked out.


Note You need to log in before you can comment on or make changes to this bug.