Bug 166228 - Vty terminals for bgpd and zebra drop the connection
Vty terminals for bgpd and zebra drop the connection
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: quagga (Show other bugs)
4.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Martin Bacovsky
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-17 22:42 EDT by Anchor Systems Managed Hosting
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version: quagga-0.98.3-2.4E
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-23 06:13:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Anchor Systems Managed Hosting 2005-08-17 22:42:14 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050725 Firefox/1.0.6 (Ubuntu package 1.0.6)

Description of problem:
I set up the /etc/quagga/zebra.conf and /etc/quagga/bgpd.conf with hostname, password and enable-password parameters (as well as other appropriate configuration items) and started the daemons. They begin listening on TCP 2601 (zebra) and TCP 2605 (bgpd) for their respective vty terminals.

Connecting to the zebra vty via telnet results in the following message:

> Hello, this is Quagga (version 0.97.0).
> Copyright 1996-2004 Kunihiro Ishiguro, et al.
> 
> 
> User Access Verification
> 
> Password:
> Vty connection is timed out.
> Connection closed by foreign host.

The session is then dropped and you are returned to the shell prompt rather than having the chance to enter the password and enter the vty.

If I try to connect to the bgpd vty (on port 2605) via telnet I get no output. I can type anything but there is no response. I have to kill the process to get out of the telnet session.

Version-Release number of selected component (if applicable):
quagga-0.97.0-1

How reproducible:
Always

Steps to Reproduce:
1. Configure quagga daemons with password and enable password options in their configuration files.
2. Start necessary quagga daemons
3. Telnet to localhost on the quagga daemon's vty port, e.g. TCP 2605 for bgpd and TCP 2601 for zebra.
  

Actual Results:  [root@sp-a quagga]# telnet 127.0.0.1 2601
Trying 127.0.0.1...
Connected to sp-a (127.0.0.1).
Escape character is '^]'.

Hello, this is Quagga (version 0.97.0).
Copyright 1996-2004 Kunihiro Ishiguro, et al.


User Access Verification

Password:
Vty connection is timed out.
Connection closed by foreign host.

Expected Results:  Should stop at the password prompt and allow password to be entered, then proceed to vty shell.

Additional info:
Comment 1 Anchor Systems Managed Hosting 2005-08-17 22:44:42 EDT
I built rpm packages from the latest stable source 0.98.4 available from
quagga.net and upgraded to that version. The problem does not exist in 0.98.4.
Comment 2 Jay Fenlason 2005-08-18 09:37:23 EDT
I had an update for RHEL-4 to upgrade Quagga to 0.98.3 (0.98.4 wasn't out 
yet), but it got dropped by the higher-ups because they didn't believe there 
was sufficient customer demand to justify the QA resources for it.  Contact 
your Red Hat Support person, give them this bugzilla #, and tell them you'd 
like an update for it. 
Comment 3 Alexander Hartmaier 2005-11-11 09:03:19 EST
We have this problem too!
Newer quagga packages for RHEL4 would be great!
Comment 4 Martin Bacovsky 2007-05-23 06:13:19 EDT
As I found this bug was already fixed in quagga-0.98.3-2.4E. If the problem is
still present after update, feel free to reopen this bug.

Note You need to log in before you can comment on or make changes to this bug.