Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1662300 - nothing provides libnetsnmp.so.35()(64bit) needed by libsane-hpaio-3.18.6-11.fc28.x86_64
Summary: nothing provides libnetsnmp.so.35()(64bit) needed by libsane-hpaio-3.18.6-11....
Keywords:
Status: CLOSED DUPLICATE of bug 1661922
Alias: None
Product: Fedora
Classification: Fedora
Component: hplip
Version: 28
Hardware: x86_64
OS: All
unspecified
urgent
Target Milestone: ---
Assignee: Zdenek Dohnal
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-12-27 12:54 UTC by customercare
Modified: 2019-01-02 09:26 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-01-02 09:26:30 UTC
Type: Bug


Attachments (Terms of Use)

Description customercare 2018-12-27 12:54:29 UTC
Description of problem:

Version 3.18.6-11 can not be updated via dnf, because of a broken depedency.
An ERASE/INSTALL attempt did not solve the problem, because an older version got installed instead of the latest version,
which in the end, resulted in the same problem again:

$ sudo dnf update --allowerasing
Letzte Prüfung auf abgelaufene Metadaten: vor 0:04:26 am Do 27 Dez 2018 13:45:47 CET.
Abhängigkeiten sind aufgelöst.

 Problem 1: cannot install the best update candidate for package libsane-hpaio-3.18.6-10.fc28.x86_64
  - problem with installed package libsane-hpaio-3.18.6-10.fc28.x86_64
  - nothing provides libnetsnmp.so.35()(64bit) needed by libsane-hpaio-3.18.6-11.fc28.x86_64
 Problem 2: cannot install the best update candidate for package hplip-libs-3.18.6-10.fc28.x86_64
  - problem with installed package hplip-libs-3.18.6-10.fc28.x86_64
  - nothing provides libnetsnmp.so.35()(64bit) needed by hplip-libs-3.18.6-11.fc28.x86_64
 Problem 3: cannot install the best update candidate for package hplip-3.18.6-10.fc28.x86_64
  - problem with installed package hplip-3.18.6-10.fc28.x86_64
  - nothing provides libnetsnmp.so.35()(64bit) needed by hplip-3.18.6-11.fc28.x86_64
========================================================================================================================
 Paket                          Arch                    Version                          Paketquelle              Größe
========================================================================================================================
Skipping packages with broken dependencies:
 hplip                          x86_64                  3.18.6-11.fc28                   updates                   16 M
 hplip-libs                     x86_64                  3.18.6-11.fc28                   updates                  204 k
 libsane-hpaio                  x86_64                  3.18.6-11.fc28                   updates                  127 k

Transaktionsübersicht
========================================================================================================================
Überspringen  3 Pakete

Nichts zu tun.
Fertig.

Comment 1 customercare 2018-12-27 13:04:03 UTC
FIX: 

push net-snmp* version 5.8-3 to stable.

$ sudo dnf update --best --allowerasing net-snmp* --enablerepo=updates-testing
Letzte Prüfung auf abgelaufene Metadaten: vor 0:01:00 am Do 27 Dez 2018 14:01:06 CET.
Abhängigkeiten sind aufgelöst.
========================================================================================================================
 Paket                            Arch                Version                        Paketquelle                  Größe
========================================================================================================================
Aktualisieren:
 hplip                            x86_64              3.18.6-11.fc28                 updates                       16 M
 hplip-common                     x86_64              3.18.6-11.fc28                 updates                      110 k
 hplip-libs                       x86_64              3.18.6-11.fc28                 updates                      204 k
 libsane-hpaio                    x86_64              3.18.6-11.fc28                 updates                      127 k
 net-snmp                         x86_64              1:5.8-3.fc28                   updates-testing              351 k
 net-snmp-agent-libs              x86_64              1:5.8-3.fc28                   updates-testing              747 k
 net-snmp-libs                    x86_64              1:5.8-3.fc28                   updates-testing              820 k
Removing dependent packages:
 corosync                         x86_64              2.4.4-1.fc28                   @fedora                      1.2 M

Transaktionsübersicht
========================================================================================================================
Aktualisieren  7 Pakete
Entfernen      1 Paket

Gesamte Downloadgröße: 18 M
Ist dies in Ordnung? [j/N]:j

Comment 2 Zdenek Dohnal 2019-01-02 09:26:30 UTC
Hi,

thank you for reporting the issue! It is actually duplicate of https://bugzilla.redhat.com/show_bug.cgi?id=1661922 .

*** This bug has been marked as a duplicate of bug 1661922 ***


Note You need to log in before you can comment on or make changes to this bug.