Bug 166240 - ksconfig crashes on ks.cfg file with firewall rule
ksconfig crashes on ks.cfg file with firewall rule
Status: CLOSED NEXTRELEASE
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: ksconfig (Show other bugs)
3.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Chris Lumens
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-18 04:13 EDT by Michel van Deventer
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-23 15:24:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michel van Deventer 2005-08-18 04:13:55 EDT
Description of problem:
When creating a custom ks.cfg file and selecting a trusted interface in the 
firewall screen (e.g. eth0) then selecting 'disable firewall' and saving the 
file is ok. But when you try to read that ks.cfg file in again in ksconfig it 
crashes with the following messages :
Traceback (most recent call last):
  File "/usr/share/redhat-config-kickstart/redhat-config-kickstart.py", line 
84, in ?
    kickstartGui.kickstartGui(file)
  File "/usr/share/redhat-config-kickstart/kickstartGui.py", line 166, in 
__init__
    self.fillData()
  File "/usr/share/redhat-config-kickstart/kickstartGui.py", line 309, in 
fillData
    self.firewall_class.fillData()
  File "/usr/share/redhat-config-kickstart/firewall.py", line 205, in fillData
    self.firewallCustomizeRadio.set_active(gtk.TRUE)
AttributeError: 'NoneType' object has no attribute 'set_active'

In the ks.cfg the firewall rule is :
#Firewall configuration
firewall --disabled --trust=eth0

It looks like it crashes on the '--trust=eth0' line, removing that statement 
fixes the problem.



Version-Release number of selected component (if applicable):
redhat-config-kickstart-2.3.22-3

How reproducible:
every time

Steps to Reproduce:
1. create custom ks.cfg file, set eth0 to trusted, disable firewall
2. save ks.cfg, quit program.
3. start ksconfig, try to load ks.cfg
  
Actual results:
ksconfig crashes with :
Traceback (most recent call last):
  File "/usr/share/redhat-config-kickstart/redhat-config-kickstart.py", line 
84, in ?
    kickstartGui.kickstartGui(file)
  File "/usr/share/redhat-config-kickstart/kickstartGui.py", line 166, in 
__init__
    self.fillData()
  File "/usr/share/redhat-config-kickstart/kickstartGui.py", line 309, in 
fillData
    self.firewall_class.fillData()
  File "/usr/share/redhat-config-kickstart/firewall.py", line 205, in fillData
    self.firewallCustomizeRadio.set_active(gtk.TRUE)
AttributeError: 'NoneType' object has no attribute 'set_active'




Expected results:

ksconfig should have loaded the ks.cfg file ignoring the --trust=eth0 or should 
not have written it in the first place.

Additional info:
Comment 1 Chris Lumens 2006-03-23 15:24:31 EST
This will be fixed in the next release of RHEL.  If you need a fix in a RHEL3
update release, please talk to your support representative who will escalate the
issue accordingly.

Note You need to log in before you can comment on or make changes to this bug.