Bug 1662411 - [admin] Operator Management needs a project-selector
Summary: [admin] Operator Management needs a project-selector
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: OKD
Classification: Red Hat
Component: Management Console
Version: 4.x
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: ---
: 4.0.0
Assignee: Samuel Padgett
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-12-28 08:55 UTC by XiaochuanWang
Modified: 2019-01-30 12:38 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-01-30 12:38:29 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description XiaochuanWang 2018-12-28 08:55:56 UTC
Description of problem:
When a project has a subscription, the Create Subscription button is hidden under current project. But subscription is namespace-level resource, so here it needs to switch to other project by project selector.

Version-Release number of selected component (if applicable):
registry.svc.ci.openshift.org/openshift/origin-v4.0-2018-12-26-190509@sha256   86f6104f0b2d69a5c0133fa92f2325bbc78c398ba1000f10927f3a9d3b36e792   7f8e4a1588a2   6 days ago      268 MB
console repo commit id: c7f598d85ba30c2a8347885d66e44d2c8be448f5

How reproducible:
Always

Steps to Reproduce:
1. User subscribe an operator for a project.
2. Keep url is under the project (same as choosing the project from project list)
3. Browse to the Operator Management and try to subscribe it again for another project.

Actual results:
3. Since Create Subscription is diabled for current project and it's namespace-level resource, it's not convenient to create a new subscription to other namepsace from current page.

Expected results:
3. The page needs a project-selector

Additional info:

Comment 1 Samuel Padgett 2019-01-16 16:17:38 UTC
https://github.com/openshift/console/pull/1028

Comment 2 XiaochuanWang 2019-01-30 07:35:29 UTC
Now that the Operator Catalogs, Operator Subscriptions and Install Plans are all name-spaced, the Operator Management page has added a project switcher as expected. Thanks and will mark this issue as verified.

# oc get clusterversion
NAME      VERSION                           AVAILABLE   PROGRESSING   SINCE     STATUS
version   4.0.0-0.alpha-2019-01-28-212509   True        False         1d        Cluster version is 4.0.0-0.alpha-2019-01-28-212509


 "io.openshift.build.commit.id": "3c3e54803fa9a223b1f4e817cc2c710e000414df"


Note You need to log in before you can comment on or make changes to this bug.