Bug 1662438 - SELinux is preventing find from 'getattr' accesses on the Verzeichnis /proc/sys/net.
Summary: SELinux is preventing find from 'getattr' accesses on the Verzeichnis /proc/s...
Keywords:
Status: CLOSED DUPLICATE of bug 1662441
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 29
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Lukas Vrabec
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:f1942d495825ef80cb15a530b31...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-12-28 14:11 UTC by Thomas Neuber
Modified: 2019-01-09 10:15 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-01-09 10:15:22 UTC


Attachments (Terms of Use)

Description Thomas Neuber 2018-12-28 14:11:23 UTC
Description of problem:
cockpit and cockpit-pcp is installed and active on this system. The SELinux alerts appear during or after system (re)start.
SELinux is preventing find from 'getattr' accesses on the Verzeichnis /proc/sys/net.

*****  Plugin catchall (100. confidence) suggests   **************************

Wenn Sie denken, dass es find standardmäßig erlaubt sein sollte, getattr Zugriff auf net directory zu erhalten.
Then sie sollten dies als Fehler melden.
Um diesen Zugriff zu erlauben, können Sie ein lokales Richtlinien-Modul erstellen.
Do
zugriff jetzt erlauben, indem Sie die nachfolgenden Befehle ausführen:
# ausearch -c 'find' --raw | audit2allow -M my-find
# semodule -X 300 -i my-find.pp

Additional Information:
Source Context                system_u:system_r:pcp_pmlogger_t:s0
Target Context                system_u:object_r:sysctl_net_t:s0
Target Objects                /proc/sys/net [ dir ]
Source                        find
Source Path                   find
Port                          <Unbekannt>
Host                          (removed)
Source RPM Packages           
Target RPM Packages           
Policy RPM                    selinux-policy-3.14.2-44.fc29.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 4.19.10-300.fc29.x86_64 #1 SMP Mon
                              Dec 17 15:34:44 UTC 2018 x86_64 x86_64
Alert Count                   2
First Seen                    2018-12-28 15:00:40 CET
Last Seen                     2018-12-28 15:00:40 CET
Local ID                      e9891812-c031-4f0e-a5eb-88c37e8ffc40

Raw Audit Messages
type=AVC msg=audit(1546005640.129:280): avc:  denied  { getattr } for  pid=7796 comm="find" path="/proc/sys/net" dev="proc" ino=18705 scontext=system_u:system_r:pcp_pmlogger_t:s0 tcontext=system_u:object_r:sysctl_net_t:s0 tclass=dir permissive=0


Hash: find,pcp_pmlogger_t,sysctl_net_t,dir,getattr

Version-Release number of selected component:
selinux-policy-3.14.2-44.fc29.noarch

Additional info:
component:      selinux-policy
reporter:       libreport-2.9.7
hashmarkername: setroubleshoot
kernel:         4.19.10-300.fc29.x86_64
type:           libreport

Comment 1 Lukas Vrabec 2019-01-09 10:15:22 UTC

*** This bug has been marked as a duplicate of bug 1662441 ***


Note You need to log in before you can comment on or make changes to this bug.