Bug 1662728 - Multiple instances of qbittorrent open when .torrent downloaded or magnetic link clicked in Firefox
Summary: Multiple instances of qbittorrent open when .torrent downloaded or magnetic l...
Keywords:
Status: CLOSED EOL
Alias: None
Product: Fedora
Classification: Fedora
Component: qbittorrent
Version: 29
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Charalampos Stratakis
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-01-01 05:17 UTC by Anton Smirnov
Modified: 2019-11-27 23:25 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-11-27 23:25:44 UTC
Type: Bug


Attachments (Terms of Use)

Description Anton Smirnov 2019-01-01 05:17:51 UTC
Description of problem:
Multiple instances of qbittorrent open when .torrent downloaded or magnetic link clicked in Firefox 

Version-Release number of selected component (if applicable):
4.1.2-1.fc29

How reproducible:
always

Steps to Reproduce:
1. Open qbt from menu
2. Open magnet link from firefox

Actual results:
New qbt is launched

Expected results:
Torrent appears in the first instance

Additional info:
It seems this bug was reported for a number of times before but
(1) still doesn't work
(2) proposed solution from bug 1371139

TMPDIR=/var/tmp
export TMPDIR

also doesn't help

Comment 1 Charalampos Stratakis 2019-09-05 17:42:40 UTC
Could you check out now if the latest version fixes the issue?

Comment 2 Anton Smirnov 2019-09-13 23:35:34 UTC
qbittorrent-4.1.5-2.fc30.x86_64, still valid

Comment 3 Anton Smirnov 2019-09-14 14:40:48 UTC
Ok, I've found a problem sort of on my side. My Firefox started qbittorrent directly and ignored menu item cli customization. I changed it to use system qBittorrent entry and now it works

Comment 4 Charalampos Stratakis 2019-09-14 17:53:53 UTC
I also updated to the latest version for F29 and F30, not sure if the problem still persists there.

https://bodhi.fedoraproject.org/updates/FEDORA-2019-2cb551904b
https://bodhi.fedoraproject.org/updates/FEDORA-2019-ce6c6de3cc

But it might be good to report it upstream.

Comment 5 Ben Cotton 2019-10-31 18:50:26 UTC
This message is a reminder that Fedora 29 is nearing its end of life.
Fedora will stop maintaining and issuing updates for Fedora 29 on 2019-11-26.
It is Fedora's policy to close all bug reports from releases that are no longer
maintained. At that time this bug will be closed as EOL if it remains open with a
Fedora 'version' of '29'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not 
able to fix it before Fedora 29 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora, you are encouraged  change the 'version' to a later Fedora 
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

Comment 6 Ben Cotton 2019-11-27 23:25:44 UTC
Fedora 29 changed to end-of-life (EOL) status on 2019-11-26. Fedora 29 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.


Note You need to log in before you can comment on or make changes to this bug.