Bug 1662938 - 502 server error when querying for a lot of bug IDs via Bug.search
Summary: 502 server error when querying for a lot of bug IDs via Bug.search
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Bugzilla
Classification: Community
Component: Performance
Version: 5.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium vote
Target Milestone: ---
Assignee: PnT DevOps Devs
QA Contact: tools-bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-01-02 13:20 UTC by Ales Zelinka
Modified: 2019-06-03 06:36 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-03 06:36:18 UTC


Attachments (Terms of Use)

Description Ales Zelinka 2019-01-02 13:20:21 UTC
Description of problem:
query xml-rpc Bug.search with 3500+ bug ids. Request dies with 502 server error.

This might simply be a case of too many individual bugs in one query but Bugzilla v4 used to handle such queries well so I'm filing it

Version-Release number of selected component (if applicable):
5.0.4.rh11

How reproducible:
always

Steps to Reproduce:
1. search for a list of 3500 individual bugzilla IDs

Comment 1 Jeff Fearn 🐞 2019-01-13 23:33:06 UTC
Are you specifying the fields you want? If not then it's probably caused by Bug 1658176

Comment 2 Jeff Fearn 🐞 2019-02-28 05:05:57 UTC
Can you test this again? Bug 1658176 should have made these requests a lot lighter.

FYI the 502 isn't the request dying, it's the proxy terminating the connection to the client. The request will actually complete but the results are lost.

Comment 3 Jeff Fearn 🐞 2019-06-03 06:36:18 UTC
I'm going to assume that this was caused by Bug 1658176 , if you can still duplicate it feel free to reopen this bug with the details.


Note You need to log in before you can comment on or make changes to this bug.