Bug 166299 - xscreensaver settings crash on any change
xscreensaver settings crash on any change
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xscreensaver (Show other bugs)
rawhide
All Linux
medium Severity high
: ---
: ---
Assigned To: Ray Strode [halfline]
:
: 166776 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-18 16:36 EDT by Trever Adams
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-19 11:47:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
ltrace with x error that shows on ltrace (2.87 KB, text/plain)
2005-08-18 16:37 EDT, Trever Adams
no flags Details
my .xscreensaver file (17.06 KB, text/plain)
2005-08-18 22:42 EDT, Trever Adams
no flags Details
Don't use iterator that may not be valid (802 bytes, patch)
2005-08-19 11:46 EDT, Ray Strode [halfline]
no flags Details | Diff

  None (edit)
Description Trever Adams 2005-08-18 16:36:25 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.11) Gecko/20050815 Fedora/1.7.11-2

Description of problem:
I go to desktop->preferences->screensavers. If I make any change (i.e. check/uncheck a screen saver, change the directory for image grabbing, etc.) the program crashes without saving the changes.

This happens every time.

Version-Release number of selected component (if applicable):
xscreensaver-base-4.22-7

How reproducible:
Always

Steps to Reproduce:
1. Go to desktop->preferences->screensavers
2. Attempt to make a change.
3.
  

Actual Results:  Program crashes without error.
Ltrace attached.

Expected Results:  Change should have been activated.

Additional info:
Comment 1 Trever Adams 2005-08-18 16:37:10 EDT
Created attachment 117881 [details]
ltrace with x error that shows on ltrace
Comment 2 Jamie Zawinski 2005-08-18 17:54:35 EDT
Doesn't happen for me on FC4 x86; can you compile with -g and run xscreensaver-demo under gdb to 
give me a backtrace with symbol names?  Also, attach your .xscreensaver file.
Comment 3 Trever Adams 2005-08-18 22:42:41 EDT
Created attachment 117897 [details]
my .xscreensaver file
Comment 4 Trever Adams 2005-08-18 22:43:43 EDT
I am not ultra familiar with SPEC files and such, so it will take me a bit to
figure out how to get the -g option in. However, this is rawhide not FC4.

I will try to get this to you this weekend.
Comment 6 Ray Strode [halfline] 2005-08-19 11:46:39 EDT
Created attachment 117918 [details]
Don't use iterator that may not be valid

Hi Jamie,

Above is a patch that I'm building into rawhide now. I think it should solve
the problem.
Comment 7 Warren Togami 2005-08-25 20:18:08 EDT
*** Bug 166776 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.