Bug 1663218 - `hammer content-view remove ...`: error message says "Access denied Missing one of the required permissions:", but problem is in wrong environment name
Summary: `hammer content-view remove ...`: error message says "Access denied Missing o...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Hammer - Content
Version: 6.5.0
Hardware: Unspecified
OS: Unspecified
unspecified
low vote
Target Milestone: Unspecified
Assignee: satellite6-bugs
QA Contact: Roman Plevka
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-01-03 13:12 UTC by Jan Hutař
Modified: 2020-02-03 16:30 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-02-03 16:30:30 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Jan Hutař 2019-01-03 13:12:35 UTC
Description of problem:
When calling `hammer content-view remove ...` with wrong environment name, it complains about insufficient permission which is confusing.


Version-Release number of selected component (if applicable):
satellite-6.5.0-5.beta.el7sat.noarch


How reproducible:
always


Steps to Reproduce:
1. Create empty CV:
   Content -> Content Views -> Create New View
      Name: test
   Get its ID. In my case it is 19
2. # hammer -u ... -p ... content-view remove --id 19 --environments Library --organization-id 1


Actual results:
# hammer -u ... -p ... content-view remove --id 19 --environments Library --organization-id 1
Could not remove objects from content view:
  Access denied
  Missing one of the required permissions: destroy_content_views, promote_or_remove_content_views


Expected results:
It should complain about environment (I have confused "lifecycle env" and "puppet env". It works with correct env provided:

# hammer -u admin -p changeme content-view remove --id 19 --environments production --organization-id 1
Could not remove objects from content view:
  There either were no environments nor versions specified or there were invalid environments/versions specified. Please check environment_ids and content_view_version_ids parameters.

Comment 3 Bryan Kearney 2020-01-15 21:01:11 UTC
The Satellite Team is attempting to provide an accurate backlog of bugzilla requests which we feel will be resolved in the next few releases. We do not believe this bugzilla will meet that criteria, and have plans to close it out in 1 month. This is not a reflection on the validity of the request, but a reflection of the many priorities for the product. If you have any concerns about this, feel free to contact Red Hat Technical Support or your account team. If we do not hear from you, we will close this bug out. Thank you.

Comment 4 Bryan Kearney 2020-02-03 16:30:30 UTC
Thank you for your interest in Satellite 6. We have evaluated this request, and while we recognize that it is a valid request, we do not expect this to be implemented in the product in the foreseeable future. This is due to other priorities for the product, and not a reflection on the request itself. We are therefore closing this out as WONTFIX. If you have any concerns about this, please do not reopen. Instead, feel free to contact Red Hat Technical Support. Thank you.


Note You need to log in before you can comment on or make changes to this bug.