Bug 166337 - evince segfault when opening pdf's
evince segfault when opening pdf's
Status: CLOSED DUPLICATE of bug 166264
Product: Fedora
Classification: Fedora
Component: evince (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Marco Pesenti Gritti
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-19 08:41 EDT by James Laska
Modified: 2013-09-02 02:06 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-19 08:48:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description James Laska 2005-08-19 08:41:43 EDT
ARCH:         i386
RPM NVR:      evince-0.3.4-1.i386
RELATED RPMS (rpm -qR evince): 

atk-1.10.1-1.i386
cairo-0.9.2-2.i386
dbus-0.35.2-1.i386
dbus-glib-0.35.2-1.i386
freetype-2.1.9-4.i386
GConf2-2.11.90-2.i386
glib2-2.8.0-1.i386
gnome-vfs2-2.11.90-3.i386
gtk2-2.8.0-2.i386
libart_lgpl-2.3.17-2.i386
libbonobo-2.10.0-1.i386
libbonoboui-2.10.0-2.i386
libglade2-2.5.1-3.i386
libgnome-2.11.2-1.i386
libgnomecanvas-2.11.1-3.i386
libgnomeprint22-2.11.0-1.i386
libgnomeprintui22-2.11.0-2.i386
libgnomeui-2.11.2-2.i386
libstdc++-4.0.1-9.i386
libtiff-3.7.2-1.i386
libxml2-2.6.20-1.i386
nautilus-2.11.91-1.i386
ORBit2-2.12.2-1.i386
pango-1.10.0-1.i386
poppler-0.4.0-2.i386
popt-1.10.2-3.i386
zlib-1.2.2.2-5.i386

evince appears to no longer open pdf's for me.  I have included gdb output of
the crash below and linked to strace output
(http://people.redhat.com/jlaska/evince.strace).  Please advise if there are
additional debugging/verification steps you would like executed.

(gdb) file /usr/bin/evince
Reading symbols from /usr/bin/evince...Reading symbols from
/usr/lib/debug/usr/bin/evince.debug...done.
Using host libthread_db library "/lib/libthread_db.so.1".
done.
(gdb) set args Desktop/IBM\ TotalStorage\ DS300\ cog.pdf
(gdb) run
Starting program: /usr/bin/evince Desktop/IBM\ TotalStorage\ DS300\ cog.pdf
Reading symbols from shared object read from target memory...done.
Loaded system supplied DSO at 0x528000
[Thread debugging using libthread_db enabled]
[New Thread -1208154448 (LWP 3210)]

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread -1208154448 (LWP 3210)]
0x00b5c00f in dbus_g_connection_register_g_object () from
/usr/lib/libdbus-glib-1.so.1
(gdb) bt
#0  0x00b5c00f in dbus_g_connection_register_g_object () from
/usr/lib/libdbus-glib-1.so.1
#1  0x0805e71f in ev_application_register_service (application=0x9df0068) at
ev-application.c:94
#2  0x080797b6 in main (argc=2, argv=0xbfaeee64) at main.c:199
Comment 1 Marco Pesenti Gritti 2005-08-19 08:48:36 EDT

*** This bug has been marked as a duplicate of 166264 ***

Note You need to log in before you can comment on or make changes to this bug.