Bug 1663452 - sos-collector with ssh keys is not working
Summary: sos-collector with ssh keys is not working
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: sos
Version: 8.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: rc
: 8.0
Assignee: Jake Hunsaker
QA Contact: BaseOS QE - Apps
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-01-04 11:36 UTC by Ulhas Surse
Modified: 2019-01-07 13:11 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-01-04 15:02:56 UTC
Type: Bug
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 3789501 0 None None None 2019-01-07 13:11:09 UTC

Description Ulhas Surse 2019-01-04 11:36:42 UTC
Description of problem:
While generating sos-collector, the process fails with error:

<hostname>  : Unable to connect: not a valid RSA private key file

Though the correct keys are installed. https://access.redhat.com/solutions/9194


Version-Release number of selected component (if applicable):
RHEL 8 Beta

How reproducible:
Always

Steps to Reproduce:
1. Configure ssh keys from RHEL8 to other nodes.
2. try to generate sos-collector without password
3.

Actual results:
sos-collector fails to generate with error:
: Unable to connect: not a valid RSA private key file

Expected results:
the process should pass.

Additional info:

Comment 2 Pavel Moravec 2019-01-04 12:02:01 UTC
Reassigning to Jake as maintainer of sos-collector.

Jake, could you pls. ask for sos-collector component in RHEL8? I see the component in RHEL7 product only, but not in RHEL8. (and I dont know where to raise such requests :( ).

Comment 3 Jake Hunsaker 2019-01-04 14:18:10 UTC
For sos-collector-1.5 you need to have the key loaded by an agent, e.g. ssh-agent.

However, this exact behavior is why we transitioned sos-collector away from paramiko as the transport since this error comes directly from paramiko not supporting the default key types in RHEL 8.

This is fixed in sos-collector-1.6

Comment 5 Jake Hunsaker 2019-01-04 15:02:56 UTC
Closing as this is resolved in sos-collector-1.6 in RHEL 8, but did not make it in time for the Beta.


Note You need to log in before you can comment on or make changes to this bug.