Bug 166359 - iscsi does not start/no config file with 2.6.9-15 U2 beta
iscsi does not start/no config file with 2.6.9-15 U2 beta
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: iscsi-initiator-utils (Show other bugs)
4.2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tom Coughlan
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-19 15:02 EDT by Alex Bruno
Modified: 2008-04-07 01:03 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-01 15:09:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alex Bruno 2005-08-19 15:02:25 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686 (x86_64); en-US; rv:1.7.10) Gecko/20050719 Red Hat/1.0.6-1.4.1 Firefox/1.0.6

Description of problem:
Customer downloaded the beta kernel.  Installed it.  Made sure to edit the /etc/modprobe.conf file to include the line

scsi_hotadapter3 iscsi_sfnet

Then they remade the initrd rd.  System boots into new kernel without error.  An lsmod shows that the iscsi module is loaded and present, but there is no detection of the iscsi device nor a blank template file /etc/iscsi

Version-Release number of selected component (if applicable):
kernel 2.6.9-15ELsmp

How reproducible:
Always

Steps to Reproduce:
1.Customer downloaded the beta kernel.  Installed it.  Made sure to edit the /etc/modprobe.conf file to include the line

scsi_hotadapter3 iscsi_sfnet

2.Then they remade the initrd rd.  System boots into new kernel without error.  An lsmod shows that the iscsi module is loaded and present, but there is no detection of the iscsi device nor a blank template file /etc/iscsi
3.
  

Actual Results:  System that has the iscsi module in it.  But no config file and no device detection.

Expected Results:  Config file should have been created? iscsi hardware should have been detected

Additional info:
Comment 1 Tom Coughlan 2005-08-22 16:11:40 EDT
The iSCSI config file is /etc/iscsi.conf, not /etc/iscsi.

You will see that it is initially all comments. Generally, all you need to do is
add one line:

DiscoveryAddress=10.4.100.1:3260

with the address of your iSCSI target. 

Then set up the iSCSI target to respond to this initiator (you may need the info
stored in /etc/initiatorname.iscsi for this). 

Then:

service iscsi restart

Also, in general, you don't need to put iscsi_sfnet in the initrd. Instead just
do the following once:

chkconfig iscsi on

(you can check the result with 
chkconfig --list | grep iscsi)

then iSCSI will be stopped/started (including driver load) on each reboot.

See also:
 
/usr/share/doc/iscsi-initiator-utils-4.0.3.0/README
man iscsi-ls
man iscsi.conf
man iscsid

Let me know if this solves your problem. 

Tom
Comment 3 Mike Christie 2007-08-01 15:09:55 EDT
I am closing this since it has been a long time to wait for a response.

Note You need to log in before you can comment on or make changes to this bug.