Bug 166374 - [RHEL4] physicalextentsize 4KB is supported (lvm2 - vgcreate manpage)
[RHEL4] physicalextentsize 4KB is supported (lvm2 - vgcreate manpage)
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: lvm2 (Show other bugs)
4.0
All Linux
low Severity low
: ---
: ---
Assigned To: Alasdair Kergon
Brian Brock
:
: 182570 (view as bug list)
Depends On:
Blocks: 181409
  Show dependency treegraph
 
Reported: 2005-08-19 16:56 EDT by Issue Tracker
Modified: 2010-10-21 23:16 EDT (History)
4 users (show)

See Also:
Fixed In Version: RHBA-2006-0504
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-10 17:45:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 5 David Milburn 2005-08-19 17:02:35 EDT
Manpage for vgcreate needs to specify the correct range for lvm2 physicalextentsize.
Comment 7 Alasdair Kergon 2005-08-30 09:07:55 EDT
"vgcreate in lvm2 allows 1 KB for minimum value in source code. It mentions
only for LVM1. should mention LVM2 also, since RHEL4 is using LVM2."
Comment 11 David Milburn 2005-10-21 17:44:14 EDT
The manpage for vgcreate delivered in lvm2-2.01.08-1.0.RHEL4 doesn't state the
correct physicalextentsize for LVM2.

-s, --physicalextentsize PhysicalExtentSize[kKmMgGtT]
      Sets  the physical extent size on physical volumes of this vol-
      ume group.  A size suffix (k for kilobytes up  to  t  for  ter-
      abytes)  is  optional, megabytes is the default if no suffix is
      present.  Values can be from 8 KB to 16 GB in powers of 2. 

The 8KB to 16GB range is specific to LVM1, it should state the correct limits
for LVM2 which would be 1KB to MAX.
Comment 15 Alasdair Kergon 2006-03-15 10:10:18 EST
*** Bug 182570 has been marked as a duplicate of this bug. ***
Comment 16 Alasdair Kergon 2006-04-06 17:09:25 EDT
Committed upstream.
Comment 22 Red Hat Bugzilla 2006-08-10 17:45:22 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2006-0504.html

Note You need to log in before you can comment on or make changes to this bug.