Bug 166393 - seinfo: realloc(): invalid next size: 0x0c98f978
seinfo: realloc(): invalid next size: 0x0c98f978
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: setools (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Walsh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-20 07:42 EDT by Robert Scheck
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: 2.1.2-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-21 17:52:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robert Scheck 2005-08-20 07:42:32 EDT
Description of problem:
# seinfo
*** glibc detected *** seinfo: realloc(): invalid next size: 0x0c98f978 ***
======= Backtrace: =========
/lib/libc.so.6[0x8db785]
/lib/libc.so.6(__libc_realloc+0x101)[0x8dc170]
seinfo[0x804f506]
seinfo[0x805eef5]
seinfo[0x80615f4]
seinfo[0x804fe39]
seinfo[0x804a777]
/lib/libc.so.6(__libc_start_main+0xdf)[0x88b49f]
seinfo[0x8049461]
======= Memory map: ========
0037a000-0038a000 r-xp 00000000 68:02 2965525    /lib/libselinux.so.1
0038a000-0038b000 rwxp 00010000 68:02 2965525    /lib/libselinux.so.1
003ad000-003b6000 r-xp 00000000 68:02 2965548    /lib/libgcc_s-4.0.1-20050817.
so.1
003b6000-003b7000 rwxp 00009000 68:02 2965548    /lib/libgcc_s-4.0.1-20050817.
so.1
00876000-0099b000 r-xp 00000000 68:02 2965561    /lib/libc-2.3.90.so
0099b000-0099d000 r-xp 00124000 68:02 2965561    /lib/libc-2.3.90.so
0099d000-0099f000 rwxp 00126000 68:02 2965561    /lib/libc-2.3.90.so
0099f000-009a1000 rwxp 0099f000 00:00 0
00aaa000-00acd000 r-xp 00000000 68:02 2965636    /lib/libm-2.3.90.so
00acd000-00ace000 r-xp 00022000 68:02 2965636    /lib/libm-2.3.90.so
00ace000-00acf000 rwxp 00023000 68:02 2965636    /lib/libm-2.3.90.so
00ca6000-00cbf000 r-xp 00000000 68:02 2965595    /lib/ld-2.3.90.so
00cbf000-00cc0000 r-xp 00018000 68:02 2965595    /lib/ld-2.3.90.so
00cc0000-00cc1000 rwxp 00019000 68:02 2965595    /lib/ld-2.3.90.so
00db9000-00dbb000 r-xp 00000000 68:02 2965629    /lib/libdl-2.3.90.so
00dbb000-00dbc000 r-xp 00001000 68:02 2965629    /lib/libdl-2.3.90.so
00dbc000-00dbd000 rwxp 00002000 68:02 2965629    /lib/libdl-2.3.90.so
00f30000-00f31000 r-xp 00f30000 00:00 0
08048000-0806f000 r-xp 00000000 68:02 378126     /usr/bin/seinfo
0806f000-08070000 rw-p 00026000 68:02 378126     /usr/bin/seinfo
08070000-08072000 rw-p 08070000 00:00 0
09d0f000-0cbe1000 rw-p 09d0f000 00:00 0          [heap]
b7400000-b7421000 rw-p b7400000 00:00 0
b7421000-b7500000 ---p b7421000 00:00 0
b75dd000-b7d1f000 rw-p b7f33000 00:00 0
b7e4a000-b7f02000 rw-p b7f38000 00:00 0
b7f59000-b7f5b000 rw-p b7f59000 00:00 0
b7f62000-b7f64000 rw-p b7f62000 00:00 0
bfb4f000-bfb64000 rw-p bfb4f000 00:00 0          [stack]
Abgebrochen
#

Version-Release number of selected component (if applicable):
setools-2.1.1-3

How reproducible:
Everytime, run "seinfo".

Actual results:
"seinfo" looks a bit broken

Expected results:
Should work... ;-)
Comment 1 Daniel Walsh 2005-08-22 09:33:27 EDT
seinfo

Statistics for policy file: /etc/selinux/strict/policy/policy.19
Policy Version: v.19
Policy Type: binary

   Classes:           55    Permissions:      205
   Types:           1558    Attributes:         0
   Users:              3    Roles:              6
   Booleans:          77    Cond. Expr.:       99
   Allow:         357539    Neverallow:         0
   Auditallow:        12    Dontaudit:     235438
   Type_trans:      2610    Type_change:       67
   Role allow:         9    Role trans:        92
   Initial SIDs:       0

 rpm -q setools
setools-2.1.1-4

Works for me?  Could you try this version?
Comment 2 Robert Scheck 2005-09-10 07:44:30 EDT
For me, it doesn't work - same problem using setools-2.1.1-4. I even rebuilt it 
myself against gcc-4.0.1-20050906 to see whether it makes a difference, but it 
doesn't.
Comment 3 Robert Scheck 2005-09-21 17:52:03 EDT
Yeah, waiting for 2.1.2 is also a possibility...works now -> closing.

Note You need to log in before you can comment on or make changes to this bug.