Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 166425 - kile: crashes in wizard
kile: crashes in wizard
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: kile (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-20 17:46 EDT by Wolfgang Raith
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-03 15:33:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
KDE Software Compilation 111469 None None None Never

  None (edit)
Description Wolfgang Raith 2005-08-20 17:46:45 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050720 Fedora/1.0.6-1.1.fc4 Firefox/1.0.6

Description of problem:
Kile crahes immediately with error code SIGSEGV when you start its wizzard via "Quick start" menu entry. 



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. execute kile 
2. enter wizzard menu 
3. select Quick start entry 
  

Actual Results:  Kile crahes immediately with error code SIGSEGV. 

Backtrace:
(no debugging symbols found)
Using host libthread_db library "/lib/libthread_db.so.1".
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread -1208264224 (LWP 3213)]
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[KCrash handler]
#4  0x06f842b5 in QListBox::item () from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#5  0x0810aa7b in ?? ()
#6  0x0810b052 in ?? ()
#7  0x0816596d in ?? ()
#8  0x08176b9e in ?? ()
#9  0x0817c5f6 in ?? ()
#10 0x0817c6ac in ?? ()
#11 0x08183c37 in ?? ()
#12 0x06ea6df4 in QObject::activate_signal ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#13 0x06ea72b4 in QObject::activate_signal ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#14 0x0564535f in KAction::activated () from /usr/lib/libkdeui.so.4
#15 0x05645484 in KAction::slotActivated () from /usr/lib/libkdeui.so.4
#16 0x05647a20 in KAction::slotPopupActivated () from /usr/lib/libkdeui.so.4
#17 0x05647caa in KAction::qt_invoke () from /usr/lib/libkdeui.so.4
#18 0x06ea6df4 in QObject::activate_signal ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#19 0x0721f206 in QSignal::signal () from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#20 0x06ec4673 in QSignal::activate () from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#21 0x06fbb5c2 in QPopupMenu::mouseReleaseEvent ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#22 0x056361cb in KPopupMenu::mouseReleaseEvent () from /usr/lib/libkdeui.so.4
#23 0x06ee5167 in QWidget::event () from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#24 0x06e420cd in QApplication::internalNotify ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#25 0x06e4302f in QApplication::notify ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#26 0x05ce9851 in KApplication::notify () from /usr/lib/libkdecore.so.4
#27 0x06dd9b4d in QETWidget::translateMouseEvent ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#28 0x06dd7f01 in QApplication::x11ProcessEvent ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#29 0x06dec008 in QEventLoop::processEvents ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#30 0x06e5a78b in QEventLoop::enterLoop ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#31 0x06e5a696 in QEventLoop::exec () from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#32 0x06e41a99 in QApplication::exec () from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#33 0x081862d4 in ?? ()
#34 0x00b9ade6 in __libc_start_main () from /lib/libc.so.6
#35 0x08075331 in ?? ()


Expected Results:  kile-1.8.1.tar.bz2

Additional info:
Comment 1 Michael Schwendt 2005-08-21 16:55:22 EDT
> (no debugging symbols found)

kile debuginfo package was not installed, when this backtrace was done.

http://fedoraproject.org/wiki/StackTraces
Comment 2 Thomas Braun 2006-01-08 17:15:17 EST
Hello

I'm currently programming in kile and also stepped around that bug in our BTS.
It _only_ apply's to Fedora, also core4.
See https://bugs.kde.org/show_bug.cgi?id=111469.

The problem lies in quickdocumentdialog.cpp at the function fillCombobox.
The returned listbox (line 929) is empty.

Because the same listbox is not empty under my system (debian sarge with kde 3.5
and qt shipped with sarge) I really don't know where the error lies.

Thanks
Thomas Braun
Comment 3 Rex Dieter 2006-01-09 10:57:59 EST
WORKSFORME on fc4.  Are you using the latest build (atm) kile-1.8.1-7?  
Comment 4 Thomas Braun 2006-01-09 13:46:00 EST
Hello,

yes im using kile-1.8.1-7.
Unfortunately I wasn't able to find a debuginfo rpm for kile, and I'm also not
used to rpm/fc4.
The Backtraces in the KDE BTS are made with the svn version of kile.
I have attached a backtrace with 1.8.1 self compiled under fc4 with ./configure
--enable-debug=full.

I will also ask in the KDE BTS if the bug for they still occurs.


Using host libthread_db library "/lib/libthread_db.so.1".
[Thread debugging using libthread_db enabled]
[New Thread -1208137248 (LWP 8351)]
[KCrash handler]
#4  0x078f5275 in QListBox::item () from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#5  0x080bbd1e in KileDialog::QuickDocument::fillCombobox (this=0x9fe88c8, 
    combo=0x9fe9020, cslist=@0xbfdf45a0, seltext=@0x9fe89c4)
    at quickdocumentdialog.cpp:943
#6  0x080c01d0 in KileDialog::QuickDocument::fillDocumentClassCombobox (
    this=0x9fe88c8) at quickdocumentdialog.cpp:492
#7  0x080c5eb2 in KileDialog::QuickDocument::readDocumentClassConfig (
    this=0x9fe88c8) at quickdocumentdialog.cpp:473
#8  0x080c9e77 in KileDialog::QuickDocument::readConfig (this=0x9fe88c8)
    at quickdocumentdialog.cpp:371
#9  0x080ca1cf in QuickDocument (this=0x9fe88c8, config=0x9c30820, 
    parent=0x9c8d478, name=0x81a3a8e "Quick Start", caption=@0xbfdf47b8)
    at quickdocumentdialog.cpp:142
#10 0x080d4b2a in Kile::quickDocument (this=0x9c8d478) at kile.cpp:1234
#11 0x080e21f9 in Kile::qt_invoke (this=0x9c8d478, _id=142, _o=0xbfdf4888)
    at kile.moc:416
#12 0x07817db4 in QObject::activate_signal ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#13 0x07818274 in QObject::activate_signal ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#14 0x05e0c94f in KAction::activated () from /usr/lib/libkdeui.so.4
#15 0x05e0ca74 in KAction::slotActivated () from /usr/lib/libkdeui.so.4
#16 0x05e0f010 in KAction::slotPopupActivated () from /usr/lib/libkdeui.so.4
#17 0x05e0f29a in KAction::qt_invoke () from /usr/lib/libkdeui.so.4
#18 0x07817db4 in QObject::activate_signal ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#19 0x07b8c796 in QSignal::signal () from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#20 0x07835633 in QSignal::activate () from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#21 0x0792c582 in QPopupMenu::mouseReleaseEvent ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#22 0x05dfca80 in KPopupMenu::mouseReleaseEvent () from /usr/lib/libkdeui.so.4
#23 0x07856127 in QWidget::event () from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#24 0x077b308d in QApplication::internalNotify ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#25 0x077b3fef in QApplication::notify ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#26 0x05b2e661 in KApplication::notify () from /usr/lib/libkdecore.so.4
#27 0x0774ab0d in QETWidget::translateMouseEvent ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#28 0x07748eb3 in QApplication::x11ProcessEvent ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#29 0x0775cfc8 in QEventLoop::processEvents ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#30 0x077cb74b in QEventLoop::enterLoop ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#31 0x077cb656 in QEventLoop::exec () from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#32 0x077b2a59 in QApplication::exec () from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#33 0x080e8fb9 in main (argc=1, argv=0xbfdf5504) at main.cpp:129

Comment 5 Rex Dieter 2006-01-09 13:50:41 EST
For giggles, are you willing to try kde-redhat's qt pkg to see if it helps? (As
I said, I don't see the crash, but I'm using these pkgs):
http://apt.kde-redhat.org/apt/kde-redhat/fedora/4/i386/RPMS.stable/
qt-3.3.5-11.0.fc4.i386.rpm
Comment 6 Thomas Braun 2006-01-09 14:30:43 EST
No, that doesn' help.
But I will now install all new updates for fc4 and then report back.

Thanks
Thomas
Comment 7 Thomas Braun 2006-01-10 16:00:23 EST
Okay now everything is uptodate, and with both version of qt (the one wihich
vomes with fc4 and your suggestion) I still get the same crash.

really wired

Thomas
Comment 8 Rex Dieter 2006-01-11 10:26:51 EST
I'm stumped, since I can't duplicate the crash.  I'll continue to keep an eye on
the upstream bug report in case any movement occurs there.
Comment 9 Thomas Braun 2006-03-07 15:13:32 EST
I tried now with fc5test3 and it does not crash anymore :)
Tested versions are 1.8.1 and 1.9rc1.

Bye
Thomas Braun
Comment 10 Rex Dieter 2006-04-03 09:51:18 EDT
kile-1.9-1 has been released to Extras.  
Please confirm if the problem is fixed or still exists.
Comment 11 Thomas Braun 2006-04-03 15:15:00 EDT
The Problem is fixed :)

Thanks
Thomas Braun
Comment 12 Rex Dieter 2006-04-03 15:33:47 EDT
Looks like all is well in the world once again.  Thanks for the feedback.

Note You need to log in before you can comment on or make changes to this bug.