Bug 166447 - Postfix does not work with nscd
Postfix does not work with nscd
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: postfix (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Thomas Woerner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-21 14:25 EDT by W. Michael Petullo
Modified: 2010-03-23 15:34 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-23 08:37:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description W. Michael Petullo 2005-08-21 14:25:47 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux ppc; en-US; rv:1.7.11) Gecko/20050815 Epiphany/1.7.4

Description of problem:
I have a laptop that connects to a network whose accounts are hosted by an LDAP server.  In order to allow disconnected operation, I user nscd to cache network information and pam_ccreds to cache passwords.  For example, nscd caches account information so that "ls -l /home/mike" shows that /home/mike is owned by mike even if the LDAP server is not available to resolve 500 -> mike.

I use fetchmail to grab email from my server.  Fetchmail and postfix work fine to deliver my mail when I am connected to my network and my LDAP server is available.  However, when I am connected to a foreign network where my LDAP server is unavailable, fetchmail and postfix do not deliver my mail properly.

Version-Release number of selected component (if applicable):
postfix-2.2.3-1

How reproducible:
Always

Steps to Reproduce:
1.  Connect to a foreign network so that the LDAP server is not available.
2.  Verify that nscd is functioning and account information is cached.
3.  Execute fetchmail.
  

Actual Results:  1 message for mike@flyn.org at mail.flyn.org (774 octets).
reading message mike@flyn.org@mail.flyn.org:1 of 1 (774 octets) fetchmail: SMTP error: 550 <mike@localhost>: Recipient address rejected: User unknown in local recipient table
fetchmail: mail from FETCHMAIL-DAEMON@imp.flyn.org bounced to mike@flyn.org
fetchmail: can't even send to mike!
 flushed

Expected Results:  Fetchmail and postfix should identify mike as a local user because nscd is running.

Additional info:
Comment 1 Thomas Woerner 2005-09-30 12:23:44 EDT
How have you configured LDAP support for postfix?

Please provide your postfix configuration.
Comment 2 W. Michael Petullo 2005-11-11 19:53:12 EST
Postfix is not configured to use LDAP.  I guess I assumed that postfix/fetchmail
should be able to identify mike using NSS.  Because libnss_ldap is used by
glibc, I thought nscd should be able to cache the lookups.  Once nscd has a
cache, postfix/fetchmail should be able resolve names when the LDAP server is
unavailable.
Comment 3 Thomas Woerner 2007-07-23 08:37:19 EDT
I am sorry, but this is not a postfix problem. Closing as NOT A BUG.
Comment 4 W. Michael Petullo 2010-03-23 15:34:25 EDT
This works fine with sssd on Fedora 12.

Note You need to log in before you can comment on or make changes to this bug.