Bug 166449 - Slow render time on firefox for large pages
Slow render time on firefox for large pages
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
5
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Christopher Aillon
http://scragz.com/tech/mozilla/test-r...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-21 14:50 EDT by Raman Gupta
Modified: 2007-11-30 17:11 EST (History)
4 users (show)

See Also:
Fixed In Version: f7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-18 14:54:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Raman Gupta 2005-08-21 14:50:28 EDT
From Bugzilla Helper:
User-Agent: Opera/8.02 (X11; Linux i686; U; en)

Description of problem:
The firefox on my Fedora Core 4 box renders many larger
pages very slowly. During the page rendering, Firefox "hangs"
completely. A good test page is:

http://scragz.com/tech/mozilla/test-rendering-time.php

This occurs whether the page is surfed to directly, or accessed via the Back 
button.

Rendering the scragz page, and others, on the same hardware and OS,
various other browsers are over 4 times faster, including Firefox for
windows:

FC4 Firefox 1.06                         42.23
FC4 Konqueror 3.4.2-0.fc4.1              13.27
FC4 Opera 8.02 build 1272                 7.08
Windows 2000 (via VMWare) Firefox 1.06    8.18
Windows 2000 (via VMWare) IE 6            7.12

All of the above times are without any extensions *or* plugins installed
(in fact, with Greasemonkey installed, Linux Firefox took over 100
seconds to render).

My kernel version is 2.6.11-1.1369_FC4 (I have the latest, 2.6.12-1.1398_FC4, 
installed but have not yet rebooted).

This was not tested on any other Linux distributions or kernels, but was 
confirmed by at least one other person on the Fedora Core users list.

Running an strace on the Firefox process while loading occurred shows a
lot of time being spent in brk() calls (usually one brk call was over
20s). Here is output from "vmstat 5" while the page rendering is occurring:

procs -----------memory---------- -swap- ---io--- --system-- ----cpu----
 r  b   swpd   free   buff  cache  si so  bi   bo   in    cs us sy id wa
 [...]
 0  0 620600  76896   7292 432368  0  0   1     4 2212  4947  7  5 88  0
 1  0 620600  76896   7316 432372  0  0   0    18 2213  4963  9  6 85  0
 [page load starts]
 5  0 620600  76772   7348 432624  0  0   6    66 2282  4882 64 10 25  1
 1  0 620600  76672   7364 432640  0  0   1     6 2205  4909 94  6  0  0
 3  0 620600  76648   7388 432652  0  0   2    20 2228  4943 92  7  0  0
 1  0 620600  76416   7412 432668  0  0   1    67 2217  4910 94  6  0  0
 2  0 620600  76408   7428 432684  0  0   1    18 2224  4889 93  7  0  0
 2  0 620600  76276   7436 432696  0  0   1     2 2210  4889 93  7  0  0
 1  0 620596  76260   7452 432712  1  0   2    18 2213  4871 91  9  0  0
 1  0 620596  76292   7468 432728  0  0   1    11 2213  4868 90 10  0  0
 [page load ends]
 3  0 620596  75384   7524 432756  0  0   6    26 2258  5537 69 12 19  0
 0  0 620596  75308   7540 432768  0  0   1    14 2215  4885 16  7 77  0
 0  0 620596  75144   7680 432840  0  0  12   161 2232  4957 10  8 81  1
 0  0 620596  75176   7696 432856  0  0   1    50 2213  4926  7  6 87  0

So swapping is not an issue. Lots of memory is available if cache is
included. Not much disk activity is happening, but the CPU is getting
hammered.

This was also tested using a completely new profile (no ~/.mozilla
directory present), with the same result.

This is easily demonstrable on any URL where the contents are large. However, 
the slow rendering time is noticeable on all URLs. Opera and Firefox/IE on 
windows, for example, just "feels" a lot faster in general.

Version-Release number of selected component (if applicable):
firefox-1.0.6-1.1.fc4

How reproducible:
Always

Steps to Reproduce:
1. Use firefox to access the provided URL.
2. Wait... and wait... and wait...

Additional info:
Comment 1 Raman Gupta 2005-08-21 16:36:40 EDT
The test using the scragz page was attempted on the same hardware/OS using the
Firefox 1.0.6 from mozilla.org to compare against the Fedora version. It was
found that the mozilla.org version performed as per expectations (established by
other browsers). I also tried Mozilla (from Fedora) and found it a bit slower,
but its speed too was in the desired ballpark:

Mozilla Firefox 1.0.6 on FC4        8.19
FC4 Mozilla 1.7.10                 11.46

This is also a good confirmation that the problem is not specific to my
profile, as the mozilla.org Firefox is using the same ~/.mozilla/firefox
profile as the Fedora version.
Comment 2 Marius Andreiana 2005-08-22 02:47:26 EDT
I get 68 seconds on FC4 firefox.

Another report from test list says:
4 sec using fc4 firefox
2 sec using fc4 konqueror might be related to pango ...
try with disabled pango..
Comment 3 Raman Gupta 2005-08-22 20:59:34 EDT
Don't know if its relevant, but just another piece of information... The "Help,
About Mozilla Firefox" page shows the following for the FC4 version:

 Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050720
Fedora/1.0.6-1.1.fc4 Firefox/1.0.6

It shows the following for the mozilla.org version:

 Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050716 Firefox/1.0.6

Notice the Gecko version difference.
Comment 4 Steve Snyder 2005-08-23 07:15:16 EDT
Another data point:

Running http://scragz.com/tech/mozilla/test-rendering-time.php on a
fully-updated FC4 system I get:

firefox-1.0.6-1.1.fc4: 7.78
mozilla-1.7.10-1.5.1: 3.90

My system is P4 @2.4GHz and 1GB RAM.  No extensions installed in Firefox.

Now, I know that 7.78 doesn't come close to 42, but Firefox shouldn't take twice
as long to render as Mozilla, should it?
Comment 5 Steve Snyder 2005-08-23 08:54:46 EDT
Same test, same versions of the software above, this time on a P3 @ 933MHz and
768MB of RAM:

firefox-1.0.6-1.1.fc4: 15.34
mozilla-1.7.10-1.5.1: 7.72

FYI.
Comment 6 petrosyan 2005-08-24 10:48:33 EDT
On Pentium M 1 GHz:

firefox-1.0.6-1.1.fc4: 11 seconds
mozilla-1.7.10-1.5.1:   5 seconds
Comment 7 John Smythe 2005-08-31 08:01:15 EDT
16.99999949359blahblahblah. And Firefox froze while it was doing it.

Konqueror did it in 9, without freezing.
Mozilla did it in 4, without freezing.
Epiphany took 9... and didn't freeze.
Firefox on FC3, 1.
Comment 8 Raman Gupta 2006-08-13 18:39:58 EDT
I still have this problem on Fedora Core 5, with Firefox 1.5.0.6.

Firefox 1.5.0.6 (from mozilla.org): 7.87
Firefox 1.5.0.6 (RPM): 22.1
Comment 9 Matěj Cepl 2007-07-18 13:33:06 EDT
Fedora Core 5 is no longer supported, could you please reproduce this with the
updated version of the currently supported distribution (Fedora Core 6, or
Fedora 7, or Rawhide)? If this issue turns out to still be reproducible, please
let us know in this bug report.  If after a month's time we have not heard back
from you, we will have to close this bug as CANTFIX.

Setting status to NEEDINFO, and awaiting information from the reporter.

Thanks in advance.
Comment 10 Raman Gupta 2007-07-18 14:54:10 EDT
This problem seems to be resolved in f7 and rawhide, at least for me. Since I am
the original reporter I will close this bug as CURRENTVERSION / f7.

Note You need to log in before you can comment on or make changes to this bug.