Bug 166505 - dhcp6c failed: interface eth0 iaid failed to be created
dhcp6c failed: interface eth0 iaid failed to be created
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: dhcpv6 (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jason Vas Dias
:
Depends On: 165882
Blocks: 168429
  Show dependency treegraph
 
Reported: 2005-08-22 13:04 EDT by Jason Vas Dias
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version: RHBA-2006-0115
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-07 13:36:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jason Vas Dias 2005-08-22 13:04:45 EDT
+++ This bug was initially created as a clone of Bug #165882 +++

From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; de-DE; rv:1.7.10) Gecko/20050720
Fedora/1.0.6-1.1.fc4 Firefox/1.0.6

Description of problem:
Trying to use dhcp6c on a client without an assigned IPv4 address to an
interface won't work.

Version-Release number of selected component (if applicable):
dhcpv6_client-0.10-13

How reproducible:
Always

Steps to Reproduce:
1. dhcp6c -d -D -f eth0
  

Actual Results:  Aug/13/2005 17:05:56 <3>[interface] (9)
Aug/13/2005 17:05:56 <5>[eth0] (4)
Aug/13/2005 17:05:56 <3>begin of closure [{] (1)
Aug/13/2005 17:05:56 <3>comment [#      information-only;] (19)
Aug/13/2005 17:05:56 <3>[send] (4)
Aug/13/2005 17:05:56 <3>[rapid-commit] (12)
Aug/13/2005 17:05:56 <3>end of sentence [;] (1)
Aug/13/2005 17:05:56 <3>[request] (7)
Aug/13/2005 17:05:56 <3>[prefix-delegation] (17)
Aug/13/2005 17:05:56 <3>end of sentence [;] (1)
Aug/13/2005 17:05:56 <3>[iaid] (4)
Aug/13/2005 17:05:56 <3>[11111] (5)
Aug/13/2005 17:05:56 <3>end of sentence [;] (1)
Aug/13/2005 17:05:56 <3>comment [#      request temp-address;] (23)
Aug/13/2005 17:05:56 <3>end of closure [}] (1)
Aug/13/2005 17:05:56 <3>end of sentence [;] (1)
Aug/13/2005 17:05:56 extracted an existing DUID from
/var/lib/dhcpv6/dhcp6c_duid: 00:01:00:01:0a:90:bb:f0:00:00:39:01:23:45
Aug/13/2005 17:05:56 link local addr is fe80::200:39ff:fe01:2345
Aug/13/2005 17:05:56 res addr is fe80::200:39ff:fe01:2345%eth0/28
Aug/13/2005 17:05:56  found an interface eth0 hardware 0xbfda77f5
Aug/13/2005 17:05:56 interface eth0 iaid failed to be created


Expected Results:  Working, like happen, if interface contain at least one IPv4
address (127.0.0.1 would work...).

Aug/13/2005 17:05:39 <3>[interface] (9)
Aug/13/2005 17:05:39 <5>[eth0] (4)
Aug/13/2005 17:05:39 <3>begin of closure [{] (1)
Aug/13/2005 17:05:39 <3>comment [#      information-only;] (19)
Aug/13/2005 17:05:39 <3>[send] (4)
Aug/13/2005 17:05:39 <3>[rapid-commit] (12)
Aug/13/2005 17:05:39 <3>end of sentence [;] (1)
Aug/13/2005 17:05:39 <3>[request] (7)
Aug/13/2005 17:05:39 <3>[prefix-delegation] (17)
Aug/13/2005 17:05:39 <3>end of sentence [;] (1)
Aug/13/2005 17:05:39 <3>[iaid] (4)
Aug/13/2005 17:05:39 <3>[11111] (5)
Aug/13/2005 17:05:39 <3>end of sentence [;] (1)
Aug/13/2005 17:05:39 <3>comment [#      request temp-address;] (23)
Aug/13/2005 17:05:39 <3>end of closure [}] (1)
Aug/13/2005 17:05:39 <3>end of sentence [;] (1)
Aug/13/2005 17:05:39 extracted an existing DUID from
/var/lib/dhcpv6/dhcp6c_duid: 00:01:00:01:0a:90:bb:f0:00:00:39:01:23:45
Aug/13/2005 17:05:39 link local addr is fe80::200:39ff:fe01:2345
Aug/13/2005 17:05:39 res addr is fe80::200:39ff:fe01:2345%eth0/28
Aug/13/2005 17:05:39  found an interface eth0 hardware 0x80693c3
Aug/13/2005 17:05:39  create iaid 3929604096 for interface eth0
Aug/13/2005 17:05:39  found an interface eth0 hardware 0xbfaa1f55
Aug/13/2005 17:05:39  found interface eth0 iaid 3929604096
Aug/13/2005 17:05:39 interface eth0 iaid is 3929604096
Aug/13/2005 17:05:39 open_netlink_socket called
Aug/13/2005 17:05:39 netlink_send_rtmsg called


Additional info:

Current CVS version of dhcp6 has still the same problem, so upstream need to be
fixed because in IPv6-only networks it makes no sense to assign an IPv6 address
to an interface.
Comment 1 Jason Vas Dias 2005-08-22 13:08:09 EDT
Fixed with dhcpv6-0.10-14_EL4 
Comment 8 Red Hat Bugzilla 2006-03-07 13:36:34 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2006-0115.html

Note You need to log in before you can comment on or make changes to this bug.