Bug 166533 - setup "Can't start Admin server"
setup "Can't start Admin server"
Status: CLOSED CURRENTRELEASE
Product: 389
Classification: Community
Component: Install/Uninstall (Show other bugs)
7.1
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Nathan Kinder
Chandrasekar Kannan
http://www.mail-archive.com/fedora-di...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-22 21:46 EDT by Adrian M. Anhood
Modified: 2015-01-04 18:19 EST (History)
5 users (show)

See Also:
Fixed In Version: 1.0.4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-08 10:24:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
setup.log from fedora-ds (10.60 KB, text/plain)
2005-08-22 21:50 EDT, Adrian M. Anhood
no flags Details
admin server error log (560 bytes, text/plain)
2005-08-22 21:54 EDT, Adrian M. Anhood
no flags Details
JAVA paths for fedora-ds (987 bytes, text/plain)
2005-08-22 21:55 EDT, Adrian M. Anhood
no flags Details

  None (edit)
Description Adrian M. Anhood 2005-08-22 21:46:42 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050721 CentOS/1.0.6-1.4.1.centos4 Firefox/1.0.6

Description of problem:


Version-Release number of selected component (if applicable):
rpm-4.3.3-9_nonptl, kernel-2.6.9-11.EL, fedora-ds-7.1-2.RHEL4

How reproducible:
Always

Steps to Reproduce:
1.Fresh installation of Enterprise Linux v4 (no openLDAP components are installed + No JAVA is installed + firewall is down + only local file authentication is active)
2.rpm -ivh fedora-ds-7.1-2.RHEL4.i386.opt.rpm
3./opt/fedora-ds/setup/setup
4.Choose any of the installation methods (1, 2, or 3)
5.Defaults are choosen for all options + passward are chosen
  

Actual Results:  Configuring Administration Tasks in Directory Server...
Configuring Global Parameters in Directory Server...
Can't start Admin server [/opt/fedora-ds/start-admin > /tmp/filey0VGql 2>&1] (error: No such file or  directory)INFO Finished with setup, logfile is setup/setup.log


Admin server will not start!!!!

Expected Results:  Admin server should start, and LDAP/Directory server should be accessable via web.  I was able to get this working on Fedora Core 3 but not Enterpise Linux v4.

Additional info:

See attached log files.
Comment 1 Adrian M. Anhood 2005-08-22 21:50:31 EDT
Created attachment 117985 [details]
setup.log from fedora-ds

This file was the same on our production server with high resources and 2gb ram
as it was on this test system with 512mb ram.  Same error occured.
Comment 2 Adrian M. Anhood 2005-08-22 21:54:32 EDT
Created attachment 117986 [details]
admin server error log

no errors here.
Comment 3 Adrian M. Anhood 2005-08-22 21:55:23 EDT
Created attachment 117987 [details]
JAVA paths for fedora-ds
Comment 4 Adrian M. Anhood 2005-08-22 21:57:54 EDT
http://www.mail-archive.com/fedora-directory-users@redhat.com/msg00230.html
Found a thread with the same error.
Comment 5 Adrian M. Anhood 2005-08-22 22:04:21 EDT
When manualy starting the admin services...

[root@station150 fedora-ds]# ./start-admin
Netscape-Enterprise/6.2 B04/18/2005 13:49
warning: daemon is running as super-user
[LS ls1] http://station150.florencefilter.com, port 43734 ready to accept requests
[root@station150 fedora-ds]#

IT LOOKS LIKE IT STARTED, BUT IS NOT A RUNNING PROCESS NOR IS IT ACCESSABLE.

29120 pts/2    00:00:00 bash
29201 ?        00:00:00 pdflush
29737 ?        00:00:00 pdflush
29981 ?        00:00:00 ns-slapd
30273 ?        00:00:00 gam_server
30374 pts/2    00:00:00 ps

When using top, ns-server appears then disappears.

Comment 6 Nathan Kinder 2005-08-22 23:38:58 EDT
Does admin server startup correctly with a non-smp kernel?

This looks similar to a known issue related to JIT crashing in the IBM JVM  on
multi-processor machines.  The IBM JVM is used in the admin server.  You can
disable JIT by editing your <server root>/admin-serv/config/jvm12.conf.  Add
"-Djava.compiler=NONE" to the jvm.option property in the above reference file. 
This should allow admin server to start up.
Comment 7 Nathan Kinder 2005-10-31 18:55:31 EST
Closing this bug since there have been no details on reproducing the issue.  If
steps to reproduce can be provided, feel free to reopen the bug.
Comment 8 Vicky 2006-01-29 14:55:39 EST
I just installed fedora-ds-1.0.1 on my Fedora Core 4 system.
Exact same problem with the admin server. It does not start, gives the same
message Can't start Admin server [/opt/fedora-ds/start-admin > /tmp/fileXXXX
2>&1] (error: No such file or  directory)

Please let me know if this has been fixed or there is a workaround.

-Vicky
Comment 9 Rich Megginson 2006-02-24 11:28:06 EST
The Admin Server in FDS 1.0.1 has a problem with SELinux.  What is the contents
of your /etc/selinux/config?
Comment 10 Adrian M. Anhood 2006-02-24 13:14:56 EST
I had solved the issue by making adjustments to the JVM.  See Comment #6 From
Nathan Kinder, where he describes the adjustments.  I did not have a
compatability issue with SELinux.  I am currently running Fedora Directory
Server on CentOS v4.2 with all updates installed.
Comment 11 Rich Megginson 2006-02-27 17:25:59 EST
How about Comment #8 from Vicky?
Comment 14 Rich Megginson 2008-04-08 10:24:35 EDT
Fedora DS 7.1 is deprecated.  I don't think this problem occurs anymore with
Fedora DS 1.0.4 or Fedora DS 1.1.  Marking as resolved.

Note You need to log in before you can comment on or make changes to this bug.