Bug 166607 - changing the package version creates problems
changing the package version creates problems
Status: CLOSED CURRENTRELEASE
Product: Fedora Infrastructure
Classification: Retired
Component: update system (Show other bugs)
unspecified
All Linux
medium Severity medium
: ---
: ---
Assigned To: Luke Macken
Bill Nottingham
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-23 15:33 EDT by Rik van Riel
Modified: 2016-09-19 22:36 EDT (History)
3 users (show)

See Also:
Fixed In Version: 1.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-23 15:41:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Rik van Riel 2005-08-23 15:33:39 EDT
Description of problem:

I tried to change the package version of an FC4 update I am pushing, and got
this error:

Mod_python error: "PythonHandler mod_python.publisher"

Traceback (most recent call last):

  File
"/usr/src/build/513032-i386/install/usr/lib/python2.2/site-packages/mod_python/apache.py",
line 332, in HandlerDispatch

  File
"/usr/src/build/513032-i386/install/usr/lib/python2.2/site-packages/mod_python/publisher.py",
line 199, in handler

  File "/mnt/redhat/fedora-updates/edit.py", line 53, in add_update
    query = """\

KeyError: email

How reproducible:

Change the package version of an update and try to apply the change.
Comment 1 Luke Macken 2005-08-23 15:41:40 EDT
Fixed.

Note You need to log in before you can comment on or make changes to this bug.