Bug 166641 - filesystem error during boot smp kernel after installing
filesystem error during boot smp kernel after installing
Status: CLOSED DEFERRED
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Stephen Tweedie
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-24 02:47 EDT by Mirko Melis
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-03 10:20:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mirko Melis 2005-08-24 02:47:50 EDT
Description of problem:
After I've installing fc4 on my system (CPU=dual xeon 2,8 GHz RAM=4GB
MB=supermicro x6dh8 RAID 1=adaptec 2010S) I've got a lot of filesystem error
(ext2_xattr_get, bad block, no such file or directory, cannot execute binary
file) during any boot up of smp kernel.
I've tried to use ext2 and ext3 filesystems and no change appear.
No error with non-smp kernel

Version-Release number of selected component (if applicable):
I use kernel 2.6.11

How reproducible:
boot up the system using smp kernel

Steps to Reproduce:
1.Install FC4
2.boot up the system using smp kernel (default)
3.see the filesystem errors
  
Actual results:
the system doesn't boot

Expected results:
boot properly

Additional info:
Comment 1 Dave Jones 2005-08-24 14:20:49 EDT
There's a raid1 corruption fix in the latest kernel in updates-testing.
I suggest using that, and running fsck over your partitions.

good luck.
Comment 2 Mirko Melis 2005-08-24 19:33:12 EDT
I've installed kernel-smp-2.6.12-1.1435_FC4.x86_64.rpm and during boot I obtain
this message:

Assertion failure in dx_probe() at fs/ext3/namei.c:381:
"dx_get_limit(entries)==dx_root_limit(dir, root->info.info_length)"

[...]

Call Trace:
  <ffffffff8013754a>{profile_task_exit+21}
  <ffffffff80138716>{do_exit+34}
  <ffffffff8024bdee>{do_unblank_screen+40}
  <ffffffff80110213>{default_do_nmi+0}
  <ffffffff80110054>{do_invalid_op+163}
  <ffffffff8806184e>{:ext3:dx_probe+400}
  <ffffffff801803d5>{sync_buffer+0}
  <ffffffff8010f25d>{error_exit+0}
  <ffffffff802089ad>{vgacon_cursor+0}
  <ffffffff8806184e>{:ext3:dx_probe+400}

[...]
Comment 3 Dave Jones 2005-08-24 20:07:38 EDT
Boot the UP kernel, and do the fsck first.
Comment 4 Mirko Melis 2005-08-25 05:30:20 EDT
the FIRST action that I do is fsck -c
and my filesystem hasn't any error or badblock
Comment 5 Dave Jones 2005-08-26 19:44:08 EDT
And you still get the assertion ? Ok, Stephen needs to see this one I guess.
Comment 6 Stephen Tweedie 2005-08-30 07:39:04 EDT
Could you please attach the _full_ oops information, including register dump etc?

Also, did you do a forced full fsck, using "fsck -f"?  "fsck -c" won't force a
full check of an ext3 filesystem --- it will usually discover that the fs is
journaled and hence doesn't need fscking, and will skip the full consistency
check after performing any necessary journal replay.
Comment 7 Dave Jones 2005-11-10 15:08:22 EST
2.6.14-1.1637_FC4 has been released as an update for FC4.
Please retest with this update, as a large amount of code has been changed in
this release, which may have fixed your problem.

Thank you.
Comment 8 Dave Jones 2006-02-03 00:59:12 EST
This is a mass-update to all currently open kernel bugs.

A new kernel update has been released (Version: 2.6.15-1.1830_FC4)
based upon a new upstream kernel release.

Please retest against this new kernel, as a large number of patches
go into each upstream release, possibly including changes that
may address this problem.

This bug has been placed in NEEDINFO_REPORTER state.
Due to the large volume of inactive bugs in bugzilla, if this bug is
still in this state in two weeks time, it will be closed.

Should this bug still be relevant after this period, the reporter
can reopen the bug at any time. Any other users on the Cc: list
of this bug can request that the bug be reopened by adding a
comment to the bug.

If this bug is a problem preventing you from installing the
release this version is filed against, please see bug 169613.

Thank you.
Comment 9 Stephen Tweedie 2006-02-03 10:20:17 EST
Closing this as DEFERRED due to inactivity; please reopen if more information
becomes available.

Note You need to log in before you can comment on or make changes to this bug.