Bug 166644 - impress crash
impress crash
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Caolan McNamara
Depends On:
  Show dependency treegraph
Reported: 2005-08-24 03:59 EDT by Kir Kolyshkin
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2005-08-24 05:14:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Kir Kolyshkin 2005-08-24 03:59:35 EDT
Description of problem:
OpenOffice Impress crashed while I was viewing some ppt presentation.

Version-Release number of selected component (if applicable):
[kir@kir ~]$ rpm -qa openoffice.org\*

How reproducible:
Happened only once, not reproducible

Steps to Reproduce:
1. Load the presentation (sorry I can not provide it)
2. Enter full-screen mode (press F5)
3. Press space bar several times
Actual results:

0x41fcab96: /usr/lib/openoffice.org2.0/program/libuno_sal.so.3 + 0x1db96
0x41fcb3e4: /usr/lib/openoffice.org2.0/program/libuno_sal.so.3 + 0x1e3e4
0xffffe420:  + 0x420 (__kernel_sigreturn + 0x0)
0x4290d359: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0xbf359
(operator<<(SvStream&, GfxLink const&) + 0xfb)
0x42918ac4: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0xcaac4
0x42918d93: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0xcad93
0x42918e46: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0xcae46
0x42918fe9: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0xcafe9
0x4290fa7d: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0xc1a7d
(Graphic::SwapOut() + 0x21)
0x452ad006: /usr/lib/openoffice.org2.0/program/libgo680li.so + 0x58006
(GraphicObject::SwapOut() + 0x2a)
0x452ad0e2: /usr/lib/openoffice.org2.0/program/libgo680li.so + 0x580e2
(GraphicObject::ImplAutoSwapOutHdl(void*) + 0x66)
0x452ad1b0: /usr/lib/openoffice.org2.0/program/libgo680li.so + 0x581b0
(GraphicObject::LinkStubImplAutoSwapOutHdl(void*, void*) + 0x1a)
0x428d05a2: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x825a2
0x428dc13e: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x8e13e
(Timer::Timeout() + 0x10)
0x428dc4b8: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x8e4b8
0x4060efe5: /usr/lib/openoffice.org2.0/program/libvclplug_gen680li.so + 0x3efe5
0x4060efd0: /usr/lib/openoffice.org2.0/program/libvclplug_gen680li.so + 0x3efd0
(SalData::Timeout() const + 0x24)
0x4022a352: /usr/lib/openoffice.org2.0/program/libvclplug_gtk680li.so + 0xa352
0xd8df06: /usr/lib/libglib-2.0.so.0 + 0x24f06
0xd8c3ee: /usr/lib/libglib-2.0.so.0 + 0x233ee (g_main_context_dispatch + 0x1dc)
0xd8f3f6: /usr/lib/libglib-2.0.so.0 + 0x263f6
0xd8f8d8: /usr/lib/libglib-2.0.so.0 + 0x268d8 (g_main_context_iteration + 0x66)
0x4022a535: /usr/lib/openoffice.org2.0/program/libvclplug_gtk680li.so + 0xa535
0x40615da1: /usr/lib/openoffice.org2.0/program/libvclplug_gen680li.so + 0x45da1
(X11SalInstance::Yield(unsigned char) + 0x29)
0x428d691c: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x8891c
(Application::Yield() + 0x50)
0x428d695a: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x8895a
(Application::Execute() + 0x26)
0x8065670: /usr/lib/openoffice.org2.0/program/soffice.bin + 0x1d670
(desktop::Desktop::Main() + 0x149a)
0x428dbd49: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x8dd49
(SVMain() + 0x45)
0x8060723: /usr/lib/openoffice.org2.0/program/soffice.bin + 0x18723 (sal_main +
0xbfcde6: /lib/libc.so.6 + 0x14de6 (__libc_start_main + 0xc6)
0x8060659: /usr/lib/openoffice.org2.0/program/soffice.bin + 0x18659
(Window::RequestHelp(HelpEvent const&) + 0x31)

Expected results:

Additional info:
Comment 1 Caolan McNamara 2005-08-24 04:05:44 EDT
I've pushed a testing update of 1.9.125 for FC4, that may have this fixed.
Without the document I cannot verify myself. Alternatively the trace above
mentions graphics swapout, so as a work around changing
tools->options->openoffice.org->memory->graphics cache to larger values might
avoid the need for graphic swapout.
Comment 2 Kir Kolyshkin 2005-08-24 05:08:55 EDT
I've updated to 1.9.125 and was not able to reproduce this bug. Still, it was
not reproduced on 1.9.117 either. So I believe it can be closed...
Comment 3 Caolan McNamara 2005-08-24 05:14:45 EDT
ok, we'll mark it as worksforme for now. I'd suspect that it's the kind of bug
that would happen while scrolling through a document, i.e. when moving from one
page to another having graphics swapped out while new ones are swapped in.
Hopefully it's truly gone in 1.9.125

Note You need to log in before you can comment on or make changes to this bug.