Bug 166738 - Firefox crashes with EMFILE (Too many open files) after tabbed browsing
Firefox crashes with EMFILE (Too many open files) after tabbed browsing
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
4
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Christopher Aillon
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-24 23:28 EDT by p thompson
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-21 11:12:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description p thompson 2005-08-24 23:28:15 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050720 Fedora/1.0.6-1.1.fc3 Firefox/1.0.6

Description of problem:
Using firefox, files are continually opened until the browser reaches the maximum open file limit for the user and crashes.



Version-Release number of selected component (if applicable):
firefox-1.0.6-1.1.fc3

How reproducible:
Always

Steps to Reproduce:
1. open firefox
2. click on links
3. repeat step 2
  

Additional info:

perl -e 'while (1) { sleep 10;system("lsof | grep firefox | wc -l");}'
661
689
715
741
777
792
817
839
855
863
874
889
895
907
913
943
963
978
991
990
1003
1008
1049
1049
1088
1115
1134
1148
1163
1172
0


read(38, 0xbfbb64d3, 1)                 = -1 EAGAIN (Resource temporarily unavailable)
read(31, 0xbfbb64af, 1)                 = -1 EAGAIN (Resource temporarily unavailable)
read(36, 0xbfbb648b, 1)                 = -1 EAGAIN (Resource temporarily unavailable)
read(4, "\372", 1)                      = 1
pipe(0x991a644)                         = -1 EMFILE (Too many open files)
Comment 1 p thompson 2005-09-06 13:28:35 EDT
Also FC4
Clicking with the middle mouse button (to open new tabs) seems to exacerbate the
problem.
For example
http://www.photosight.ru/list_category.php?id=3
Middle click on the pictures and watch the count of open files rise.
Files do not close when the tabs are closed.
Comment 2 Robin 2005-10-05 12:51:56 EDT
For what it is worth, this occurs in Mozilla as well.  I moved to mozilla from
firefox after the number of crashes became a problem.  Guess the problem is
common to both. :(

I will look into it more as I had a couple of crashes that occured quite quickly
next to each other.
Comment 3 Robin 2005-10-05 14:57:15 EDT
Well, after trying to crash Mozilla since I made my post, I would have to say
that the fault with Mozilla is different than this particular bug.

I have ran the perl script since I posted before and the file count is actually
lower than when I started.  Both Firefox and Mozilla would crash in the exact
same way and while doing the exact same thing.   Both involved much tab opening
and closing.  I will keep looking to see if I can find something common.

Sorry for the misdirection.
Comment 4 p thompson 2005-10-20 22:45:11 EDT
latest fedora version of mozilla still has this bug
Comment 5 p thompson 2005-10-21 11:13:02 EDT
It ends up the config.xml I spoke of was a relic of an old version of
greasemoney I had apparently installed a year ago under an old version of Fedora.
It did not show up in the Tools->Extensions nor in installed-extensions.txt but
none the less the config.xml lived in its e4a8a97b-f2ed-450b-b12d-ee082ba24781
directory.
I biffed that directory and things seem to be working better.
Comment 6 p thompson 2005-10-21 11:13:34 EDT
Hmm, didn't speak of config.xml here, but rather at mozilla.org.
Anyway that was the problem.

Note You need to log in before you can comment on or make changes to this bug.