This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 166752 - IPv6 FF1x:: multicast addresses don't work
IPv6 FF1x:: multicast addresses don't work
Status: CLOSED CURRENTRELEASE
Product: Red Hat Cluster Suite
Classification: Red Hat
Component: cman (Show other bugs)
4
All Linux
medium Severity low
: ---
: ---
Assigned To: Christine Caulfield
Cluster QE
:
Depends On:
Blocks: 180185
  Show dependency treegraph
 
Reported: 2005-08-25 06:24 EDT by Christine Caulfield
Modified: 2009-04-16 16:00 EDT (History)
1 user (show)

See Also:
Fixed In Version: U4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-03 08:07:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Christine Caulfield 2005-08-25 06:24:43 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.7.10) Gecko/20050720 Fedora/1.0.6-1.1.fc4 Firefox/1.0.6

Description of problem:
In theory, people using local-only multicast address with IPv6 should use FF1x addresses - eg FF15::1 would be a site multicast suitable for cman to use.

However, using this address with cman simply produces lots of:

  CMANsendmsg failed: -99

errors in syslog and machines all form single-node clusters

FF05:: multicast addresses work fine.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. cman_tool join -X -e3 -ccluster -m ff15::1 -ieth0 -n <ip6 address>

  

Actual Results:  CMANsendmsg failed: -99
CMANsendmsg failed: -99               
CMANsendmsg failed: -99
CMANsendmsg failed: -99
CMANsendmsg failed: -99
CMAN: forming a new cluster


Expected Results:  Joining an existing cluster if available - without the error messages.

Additional info:

This happens because cman sends out of the socket that is bound to the multicast address rather than the one that is bound to the local address. I'm not sure why it only affects FF1x:: addresses though!

Though it sounds simple fixing cman to send out of the local socket (but to the multicast address) needs some jiggery-pokery in the code. As there's an easy workaround I'll leave this at low priority and unfixed unless someone really needs it.
Comment 1 Christine Caulfield 2005-11-15 10:32:11 EST
Fix checked into STABLE branch.

I'll let others pound on it for a while before considering it for RHEL4

Checking in cman/cman_tool/join.c;
/cvs/cluster/cluster/cman/cman_tool/join.c,v  <--  join.c
new revision: 1.12.2.7.4.1.2.2; previous revision: 1.12.2.7.4.1.2.1
done
Checking in cman/cman_tool/main.c;
/cvs/cluster/cluster/cman/cman_tool/main.c,v  <--  main.c
new revision: 1.12.2.7.6.2; previous revision: 1.12.2.7.6.1
done
Checking in cman-kernel/src/cnxman-private.h;
/cvs/cluster/cluster/cman-kernel/src/cnxman-private.h,v  <--  cnxman-private.h
new revision: 1.12.2.2.6.1; previous revision: 1.12.2.2
done
Checking in cman-kernel/src/cnxman.c;
/cvs/cluster/cluster/cman-kernel/src/cnxman.c,v  <--  cnxman.c
new revision: 1.42.2.12.4.1.2.5; previous revision: 1.42.2.12.4.1.2.4
done
Comment 2 Christine Caulfield 2006-01-03 04:25:26 EST
For the record, this checkin is also needed for the fix:

/cvs/cluster/cluster/cman/cman_tool/join.c
revision 1.12.2.7.4.1.2.3
date: 2005/11/28 14:14:21;  author: pcaulfield;  state: Exp;  lines: +1 -1
Use correct fd
Comment 3 Christine Caulfield 2006-01-06 08:35:46 EST
Now committed to RHEL4 for U4

Checking in cman/cman_tool/join.c;
/cvs/cluster/cluster/cman/cman_tool/join.c,v  <--  join.c
new revision: 1.12.2.9; previous revision: 1.12.2.8
done
Checking in cman-kernel/src/cnxman-private.h;
/cvs/cluster/cluster/cman-kernel/src/cnxman-private.h,v  <--  cnxman-private.h
new revision: 1.12.2.3; previous revision: 1.12.2.2
done
Checking in cman-kernel/src/cnxman.c;
/cvs/cluster/cluster/cman-kernel/src/cnxman.c,v  <--  cnxman.c
new revision: 1.42.2.20; previous revision: 1.42.2.19
done

Note You need to log in before you can comment on or make changes to this bug.