Bug 166767 - gnome-terminal transparency spikes X cpu utilization even when windows is rolled or minimized
gnome-terminal transparency spikes X cpu utilization even when windows is rol...
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: vte (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Warren Togami
NA
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-25 10:17 EDT by Tripp Sims
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-25 21:56:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tripp Sims 2005-08-25 10:17:21 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.10) Gecko/20050716 Firefox/1.0.6

Description of problem:
When transparency is turned on in gnome-terminal X cpu utilization should be expected to rise if your dumping a text file to stdout.  However, when that window is minimized or rolled, X continues to utilize the exact same ammount of CPU even though its not actually rendering anything to screen.

Version-Release number of selected component (if applicable):
gnome-terminal-2.10.0-2

How reproducible:
Always

Steps to Reproduce:
1.Set transparency to a 50% value.
2.Cat a large text file in a gnome-terminal with transparency on.
3.Minimize window (or roll it up).
4.X CPU use stays the same.
5.Turn transparency off.
6.Cat the same file, X CPU use is lower as expected.
7.But when you minimize the window (or roll up) X cpu use appears to decrease
  

Actual Results:  X uses CPU when it doesn't seem like it should need to.  Is this a bug in X or is gnome-terminal sending X data it doesn't need?

Expected Results:  X cpu use should go down when there is nothing on the screen for it to render (ie; a minimized windows having text streamed to it)

Additional info:
Comment 1 Ray Strode [halfline] 2005-08-25 11:28:46 EDT
Hi Tripp,

This is actually a vte bug (the rendering widget used by gnome-terminal), not a
gnome-terminal bug.  I'm going to reassign.
Comment 2 Warren Togami 2005-08-25 21:55:16 EDT
Please be sure to file this upstream at bugzilla.gnome.org, because this task is
not something Fedora has engineering resources to prioritize.

Note You need to log in before you can comment on or make changes to this bug.