Bug 166768 - kmail doesn't respond to input
kmail doesn't respond to input
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kdepim (Show other bugs)
3
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Ngo Than
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-25 10:20 EDT by Kyuso Cahi
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: FC5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-03 10:16:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kyuso Cahi 2005-08-25 10:20:47 EDT
Description of problem:

Kmail will not respond to any keyboard or mouse events in any components (menu,
window, etc.)
Kmail gives an error while quitting, but doesn't actually die

Version-Release number of selected component (if applicable):
kdepim-3.4.2-0.fc3.1
kdebase-3.4.2-0.fc3.3
iiimf-x-12.1-10.FC3.1
qt-3.3.4-0.fc3.0

How reproducible:
Always

Steps to Reproduce:
1. run kde through kdm
2. start kmail from anywhere (command line, menu, etc.)
3. click on anything after kmail opens
4. quit

Actual results:
1. No response from events
2. when quit, gives 'QInputContext: no input method context available', and
doesn't die (only closes window)

Expected results:
1. select menu or item when key/mouse event
2. quit without error message

Additional info:
This happened after updating from kde 3.3 to kde 3.4; kmail worked perfectly in
kde 3.3.

Updating from kdebase-3.4.2-0.fc3.1 to kdebase-3.4.2-0.fc3.3 solved the
following worse problems:
In kmail, everytime a key or mouse event pressed, an error is displayed: QInput
not ... available (don't remember exact phrase) and no other response

kedit works with foreign input method and key events, so it must be specific to
kmail.

When running kmail from another workstation with kde 3.3 using shared home
repository, it hangs with a process running:
  kdeinit: kconf_update --check kmail.upd
kmail 3.4 must have modified settings that kmail 3.3 can't decode properly.
Comment 1 Ngo Than 2006-05-03 10:16:11 EDT
FC3 is not supported anymore. You should please update to FC5 current release.
The new kde-3.5.2 in FC5 update should fix this above issue. Thanks for your report.

Note You need to log in before you can comment on or make changes to this bug.