Bug 166780 - rpm complains about the rpm package when trying to update rpm
rpm complains about the rpm package when trying to update rpm
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: rpm (Show other bugs)
3.0
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Paul Nasrat
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-25 13:23 EDT by Beth Nackashi
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-25 13:29:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Beth Nackashi 2005-08-25 13:23:05 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050512 Red Hat/1.0.4-1.4.1 Firefox/1.0.4

Description of problem:
Do a *non-kickstart* (HTTP) install of RHEL 3 U5 AS onto an x86_64 machine.

Notice that two versions of rpm-libs are installed.  One is for x86_64 and one is for i386:

[root@fmoquete-64 root]# rpm -qa|grep rpm
rpm-python-4.2.3-21_nonptl
rpm-4.2.3-21_nonptl
***rpm-libs-4.2.3-21_nonptl
rpmdb-redhat-3-0.20050512
redhat-java-rpm-scripts-1.0.2-2
***rpm-libs-4.2.3-21_nonptl

Try to update rpm/rpm-libs/rpm-python:

[root@fmoquete-64 root]# up2date --get rpm rpm-libs rpm-python

Fetching all package list for channel: rhel-x86_64-as-3...
########################################

Fetching package list for channel: rhel-x86_64-as-3...
########################################

rpm-4.2.3-24_nonptl.x86_64.rpm...
########################################

rpm-libs-4.2.3-24_nonptl.x86_64.rpm...
########################################

rpm-python-4.2.3-24_nonptl.x86_64.rpm...
########################################

[root@fmoquete-64 root]# cd /var/spool/up2date/
[root@fmoquete-64 up2date]# rpm -Uvh rpm-4.2.3-24_nonptl.x86_64.rpm rpm-libs-4.2.3-24_nonptl.x86_64.rpm rpm-python-4.2.3-24_nonptl.x86_64.rpm
warning: rpm-4.2.3-24_nonptl.x86_64.rpm: V3 DSA signature: NOKEY, key ID db42a60e
error: Failed dependencies:
        rpm = 4.2.3-21_nonptl is needed by (installed) rpm-libs-4.2.3-21_nonptl

This should work.  The only way to get it to work is to remove one of the rpm-libs (notice you get an error message when removing rpm-libs, but it works anyway):

[root@fmoquete-64 up2date]# rpm -q rpm-libs
rpm-libs-4.2.3-21_nonptl
rpm-libs-4.2.3-21_nonptl
[root@fmoquete-64 up2date]# rpm -e rpm-libs
error: "rpm-libs" specifies multiple packages
[root@fmoquete-64 up2date]# rpm -q rpm-libs
rpm-libs-4.2.3-21_nonptl

And now the rpm-* packages can be updated:

[root@fmoquete-64 up2date]# rpm -Uvh rpm-4.2.3-24_nonptl.x86_64.rpm rpm-libs-4.2.3-24_nonptl.x86_64.rpm rpm-python-4.2.3-24_nonptl.x86_64.rpm
warning: rpm-4.2.3-24_nonptl.x86_64.rpm: V3 DSA signature: NOKEY, key ID db42a60e
Preparing...                ########################################### [100%]
   1:rpm-libs               ########################################### [ 33%]
   2:rpm                    ########################################### [ 67%]
   3:rpm-python             ########################################### [100%]


A kickstart install will not reproduce this problem because only one version of rpm-libs will be installed.

Version-Release number of selected component (if applicable):
rpm-4.2.3-21

How reproducible:
Always

Steps to Reproduce:
1.  Whoops.  I accidentally put all of this in the Description section.
2.
3.
  

Additional info:
Comment 1 Paul Nasrat 2005-08-25 13:29:49 EDT
This does not seem like an rpm bug - merely confusion about multilib system. For
multilib we supply both libraries for most packages. Compat arch support is
selected by default meaning both will be installed.

up2date should be able to update multilib - ie up2date rpm should have worked
through depsolving. Perhaps up2date --get needs to be taught to obtain all
installed archs, but that's not an rpm bug.

Note rpm -e rpm-libs.i386 will erase the i386 rpm-libs package

Note You need to log in before you can comment on or make changes to this bug.