Bug 166787 - (70007)The timeout specified has expired: ap_content_length_filter: apr_bucket_read() failed
(70007)The timeout specified has expired: ap_content_length_filter: apr_bucke...
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: httpd (Show other bugs)
4.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Joe Orton
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-25 14:34 EDT by chris suttles
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-26 12:34:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description chris suttles 2005-08-25 14:34:43 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4

Description of problem:
When running httpd-2.0.52-12.1.ent and Bugzilla version 2.18.3 on RHEL4 U1, submitting a bug fails with the following error: 

[Thu Aug 25 10:09:50 2005] [error] [client 192.168.1.64] (70007)The timeout specified has expired: ap_content_length_filter: apr_bucket_read() failed, referer: http://host.domain.com/enter_bug.cgi?product=Other





Version-Release number of selected component (if applicable):
httpd-2.0.52-12.1.ent

How reproducible:
Always

Steps to Reproduce:
1.Install affected software
2.Open up bugzilla on the test machine (browsing still works)
3.Submit a bug
  

Actual Results:  [Thu Aug 25 10:09:50 2005] [error] [client 172.16.20.101] (70007)The timeout specified has expired: ap_content_length_filter: apr_bucket_read() failed, referer: http://logger.choicepay.com/enter_bug.cgi?product=Other

Expected Results:  A new bug should have been submitted. 

Additional info:
Comment 1 Joe Orton 2005-08-26 04:00:38 EDT
The error message means simply that a CGI script has failed to produce any
output within the configured timeout.  The timeout is controlled by the
"Timeout" setting -- 120 seconds by default.   Are you sure that the bugzilla
set up is correct?

The SELinux settings can often affect CGI script behaviour on RHEL4; it's useful
to check for any relevant avc denial messages in dmesg.
Comment 2 chris suttles 2005-08-26 09:07:06 EDT
Thanks for your suggestions.  :)

SELinux is set to permissive, and the timeout is set to 600. I am working with 
another individual on this, and although I did not set up Bugzilla, I have 
confidence that it was set up correctly. 

We have also tried updating httpd and dependencies to the newer packages still 
in beta for U2, but no luck. We have rolled back to the U1 release of said 
packages at this point, but the problem persists. 
Comment 3 chris suttles 2005-08-26 12:34:19 EDT
After looking more closely at the issue, it turns oout it was timing out due to 
a misconfiguration of postfix. The issue is now resolved. thanks again. 

Note You need to log in before you can comment on or make changes to this bug.