Bug 166795 - Make crashes / breaks while attempting to run menuconfig for cross kernel configuration
Make crashes / breaks while attempting to run menuconfig for cross kernel con...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: make (Show other bugs)
4
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Jakub Jelinek
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-25 15:34 EDT by Nathan M
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-25 18:22:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nathan M 2005-08-25 15:34:25 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050720 Fedora/1.0.6-1.1.fc4 Firefox/1.0.6

Description of problem:
While attempting to run "make menuconfig" or "make config" for an arm-linux kernel that resides on this i386 dev machine the following occurs:

===code======================================================
[root@localhost linux]# make menuconfig
  HOSTCC  scripts/basic/fixdep
  HOSTCC  scripts/basic/split-include
  HOSTCC  scripts/basic/docproc
  HOSTCC  scripts/kconfig/conf.o
  HOSTCC  scripts/kconfig/mconf.o
scripts/kconfig/mconf.c:91: error: static declaration of 'current_menu' follows non-static declaration
scripts/kconfig/lkc.h:63: error: previous declaration of 'current_menu' was here
make[1]: *** [scripts/kconfig/mconf.o] Error 1
make: *** [menuconfig] Error 2
=============================================================

Version-Release number of selected component (if applicable):
make-3.80-7

How reproducible:
Always

Steps to Reproduce:
1. Download arm-linux kernel (2.6.7) "Linux - kernel, drivers and patches" from http://www.compulab.co.il/armgx-developer.htm
2. Extract, patch and move kernel to /usr/src/arm/ as instructed by documenation (included in "Linux - kernel, drivers and patches")
3. cd /usr/src/arm/linux/
4. make menuconfig
  

Actual Results:    HOSTCC  scripts/basic/fixdep
  HOSTCC  scripts/basic/split-include
  HOSTCC  scripts/basic/docproc
  HOSTCC  scripts/kconfig/conf.o
  HOSTCC  scripts/kconfig/mconf.o
scripts/kconfig/mconf.c:91: error: static declaration of 'current_menu' follows non-static declaration
scripts/kconfig/lkc.h:63: error: previous declaration of 'current_menu' was here
make[1]: *** [scripts/kconfig/mconf.o] Error 1
make: *** [menuconfig] Error 2


Expected Results:  menuconfig should have opened up

Additional info:

"make menuconfig" worked fine with the same arm-linux kernel source code on a system running Mandriva 2005 LE x86_64.

The arm-linux kernel source can be obtained from:
http://www.compulab.co.il/armgx-developer.htm
"Linux - kernel, drivers and patches" under "Operating Systems"
Comment 1 Jakub Jelinek 2005-08-25 18:22:57 EDT
1) there is no make crash and this has nothing to do with make
2) there is a bug in scripts/kconfig/{lkc.h,mconf.c}, which older versions
   of gcc didn't issue a diagnostic about
   This has been fixed in 2.6.9:
diff -Nru a/scripts/kconfig/lkc.h b/scripts/kconfig/lkc.h
--- a/scripts/kconfig/lkc.h     2004-10-18 14:55:54 -07:00
+++ b/scripts/kconfig/lkc.h     2004-10-18 14:55:54 -07:00
@@ -59,9 +59,6 @@
 struct file *file_lookup(const char *name);
 int file_write_dep(const char *name);

-extern struct menu *current_entry;
-extern struct menu *current_menu;
-
 /* symbol.c */
 void sym_init(void);
 void sym_clear_all_valid(void);

Closing as NOTABUG, since it is not a distro bug, but bug in the kernel you
are compiling.

Note You need to log in before you can comment on or make changes to this bug.