Bug 16681 - Trident blade3d: Acer FP551 -> no luck
Trident blade3d: Acer FP551 -> no luck
Status: CLOSED DUPLICATE of bug 16596
Product: Red Hat Linux
Classification: Retired
Component: Xconfigurator (Show other bugs)
7.1
i386 Linux
low Severity low
: ---
: ---
Assigned To: Preston Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-08-21 10:54 EDT by giulioo
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-12-10 10:49:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description giulioo 2000-08-21 10:54:09 EDT
Trident Microsystems|Blade 3D PCI/AGP
Acer FP551 (LCD)
rc1

1) If I choose "Acer FP551":
- X pre-start grey screen is trembling, with kind of waves
- when gnome starts, the screen is trembling, too much
- the lower part of the screen is not visible, it seems it thinks my 
screen il taller than it actually is; so I cannot use the gnome button, 
applets..  Tried xvidtune but couldn't adjust it.
- if I test Xconfigurator at 600x800 the screen goes power save.

2) If I choose "generic LCD 1024x..."
- X pre-start grey screen is trembling, with kind of waves
(the same for the background when you log-off)
- when gnome starts, the screen is trembling a bit. It's much, much better 
then above, though. Still unusable for more that a few minutes if you care 
for your eyes.
- the screen is almost completely centered (just a to be moved left a bit) 
and can be easily adjusted with xvidtune.


The very same hardware works with Windows.
Comment 1 Trond Eivind Glomsrxd 2000-08-21 11:53:11 EDT
Tried using the XFree 4 driver?
Comment 2 giulioo 2000-08-21 12:46:42 EDT
I have trident blade 3d.
When I run Xconfigurator it says
XFree3 server: SVGA
XFree4 driver: no match
--preferxf4 does not change this.
I interpret this as meaning that there's no Xfree4 driver for my card; if 
there's a trick to make it work with XFree4, please, tell me :-)
Comment 3 Trond Eivind Glomsrxd 2000-08-21 13:12:50 EDT
Try 4.3.53+ at http://people.redhat.com/teg/xc/
Comment 4 giulioo 2000-08-22 11:51:10 EDT
No improvements with xfree4 driver.

Comment 5 Trond Eivind Glomsrxd 2000-08-22 11:52:30 EDT
ls -l /etc/X11/X shows?
Comment 6 giulioo 2000-08-22 12:34:25 EDT
$ ls -l /etc/X11/X
lrwxrwxrwx    1 root     root           22 ago 22 15:13 /etc/X11/X -> /usr/X11R6
/bin/XFree86

I made the link by hand.
Comment 7 Trond Eivind Glomsrxd 2000-08-22 13:10:15 EDT
Which server would you prefer for this card? 3 or 4?
Comment 8 giulioo 2000-08-22 17:19:46 EDT
3 for reliability, 4 for "performance"; So basically it's 3.
However this combination of monitor and card is unusable, at least for me. I'll 
try to get another card for future tests to see if I'll be able to finally have 
a linux workstation :)

More details

=== v3:
a) choosing AcerFP551: screen chopped, unusable
b) choosing LCD 1024x: screen 98%  centered (adjustable with xvidtune); small 
kind of waves visible on white background, very annoying.
===

=== v4:
a) choosing AcerFP551: better than v3b, very small kind of waves visible on 
white background; this is the best setup. However, I would not use such a set 
up for normal use. Someone with not "sharp" eyes could :-)
b) choosing LCD 1024x: same as v3b

IMPORTANT NOTE: v4 regularly hangs the system (power cycle needed) running 
xvidtune (and maybe something else I've not tried).
===

See bug 16596 for similar results.
Comment 9 giulioo 2000-08-23 11:28:59 EDT
I've tried the very same monitor on an i810 system using i810_drv.o from rc1 
updates.

I get the same results: small waves on screen, character are moving...

I use 1024x728 16bit

== Choosing AcerFP551:
xvidtune says: Pix clock 78.80, Hor: 60.06, Ver: 75.08
Monitor osd: Hor: 60.15 Ver: 75.36

== Choosing Generic LCD 1024
Vert refresh is set to 60 and Hor to 48.

Under Win98 the monitor is perfect and it's managed with the same frequencies, 
monitor osd says: Hor: 60.15,  Ver:75.12  (1024x728, 16bit)

I have the Acer cdrom with the win drivers, is there something that I may look 
for into this cd to tweak the linux settings so that it will work on linux too?


Comment 10 Trond Eivind Glomsrxd 2000-08-23 14:49:30 EDT
Not that I know of....
Comment 11 Trond Eivind Glomsrxd 2000-10-04 12:05:05 EDT
Tried 7.0 final?
Comment 12 giulioo 2000-10-04 13:54:17 EDT
I'm on an ISDN line, cannot d/l ISO images.
When the boxed set arrive I'll let you know.
Comment 13 Trond Eivind Glomsrxd 2000-12-04 17:40:38 EST
Ping?
Comment 14 giulioo 2000-12-05 02:25:44 EST
1 packets transmitted, 0 packets received, +1 errors, 100% packet loss
echo-reply will come when boxed set will be here :-)

However, since 2 months have passed, maybe I could have started downloading via 
isdn...
Comment 15 giulioo 2000-12-06 08:20:30 EST
rh70 arrived.
Unfortunately, no behavior changes for the TridentBlade3d/AcerFP551 combo.

xf3: all is trembling, does not crash.

xf4: somehow good setup (still small trembling, I would not use it for a long 
time), crashes. 
Once it froze just after "startx". Then I was able to startx, and needed to use 
xvidtune to center the image that was too much to the right, after 
clicking "test" in xvidtune it froze and then rebooted spontaneously.

During install I had another monitor (an Olidata); in anaconda I did "test X 
config" and all the GUI was messed up, then I re-did the same things without 
testing X, and after install I could do "startx" and get X running even if the 
right and left sides of the screen were ) ( instead of | |.

In the next days I'll try i810/AcerFP551, TridentBlade3d/Philips150P(LCD) and 
i810/Philips150P(LCD); I'll just move the HD to a new PC, hope 
kudzu+xconfigurator will set everything up :-)
 
Comment 16 giulioo 2000-12-10 09:03:31 EST
I've tried AcerFP551 and PhilipsBrilliance150P (both LCD) on an i810 system, 
they both work perfectly (after you play with phase/clock OSD settings).
Both of them have image noise issues on the blade3d system (could not solve 
them with phase/clock).
So it seems that, like for bug 16596, the problem here is simply that blade3d 
is not supported perfectly by XFree86 (v3 and v4).

Note for Xconfigurator for i810 and Philips150P:
- It defaults to 1024x768@75, but the manual of the monitor says that the best 
setup is 1024x768@60. Windows driver defaults to 60 VHz as 'optimal setup'.
The manual repeatedly says so, because it may seem weird that 60 is better then 
75, since the monitor can do 75:
"... Recommended video mode for Philips 150P/150B/140S: 1024x768 @60Hz for 
Philips 181AS1280x1024@60Hz...."
"... For LCD monitors, the refresh rate is much less relevant. LCD monitors 
display a stable,flicker-free image at 60Hz..."
"...  Maximum 1024 x 768 at 75Hz
      Recommended 1024x768 at 60Hz ..."
- Xconfigurator defaults to enable dri which causes 'flashing' (see bug 18522)

Comment 17 giulioo 2001-01-03 13:07:52 EST

*** This bug has been marked as a duplicate of 16596 ***

Note You need to log in before you can comment on or make changes to this bug.