Bug 166845 - After Inputing Japanense or Korean with iiim on evolution, text colour become white .
Summary: After Inputing Japanense or Korean with iiim on evolution, text colour becom...
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: pango (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Behdad Esfahbod
QA Contact:
URL:
Whiteboard:
Keywords: Reopened
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-08-26 12:36 UTC by sangu
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version: 1.13.3-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-12 12:55:36 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Input Japanese On Evolution. (100.07 KB, image/jpeg)
2005-08-26 12:36 UTC, sangu
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Bugzilla 315599 None None None Never

Description sangu 2005-08-26 12:36:03 UTC
Description of problem:
After Inputing Japanense or Korean with iiim on evolution, text colour become
white around widget.

Subject or Sender Contains:                                          Find Now 
                           ------------------------------------------

Input                           This TextArea

* Japanese
 Japanese -> Chinese

* Korean
Preedit -> Enter Key Clicking

Text colour becomes white.

Version-Release number of selected component (if applicable):
gtk2-2.8.0-2

How reproducible:
always

Steps to Reproduce:
1. Input Korean or Japanese for Searching Subject or Sender Contains
2.
3.
  
Actual results:


Expected results:


Additional info:

cairo-1.0.0-1, pango-1.10.0-1, evolution-2.3.8-1

Comment 1 sangu 2005-08-26 12:36:03 UTC
Created attachment 118149 [details]
Input Japanese On Evolution.

Comment 2 sangu 2005-08-26 13:06:52 UTC
Changing Input method, message display below. 

Gdk-WARNING **: gdk_property_get(): length value has wrapped in calculation (did
you pass G_MAXLONG?)


Comment 3 sangu 2005-08-30 17:11:58 UTC
comment 2 was fixed in gtk2-2.8.3. But comment 1 still happens.

Comment 4 Matthias Clasen 2005-09-30 21:41:42 UTC
Owen started writing a patch for this.

Comment 5 sangu 2006-06-22 09:39:02 UTC
After updating pango 1.13.2-1, this problem happens again.
See Also : http://bugzilla.gnome.org/show_bug.cgi?id=315599

Comment 6 Behdad Esfahbod 2006-06-22 21:41:26 UTC
Regression caused by me.  Will fix it for next pango release.  It's being
tracked  in the same upstream bug.


Note You need to log in before you can comment on or make changes to this bug.