This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 166864 - Daily logwatch kernel.conf generates egrep error in email results
Daily logwatch kernel.conf generates egrep error in email results
Status: CLOSED DUPLICATE of bug 162947
Product: Fedora
Classification: Fedora
Component: logwatch (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ivana Varekova
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-26 11:45 EDT by Richard Black
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-29 04:40:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Richard Black 2005-08-26 11:45:41 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5) Gecko/20041109 Firefox/1.0

Description of problem:
Daily logwatch report generates the following email:

Date: Fri, 26 Aug 2005 04:02:19 -0500
From: root <root@chinstrap.cpqlinux.com>
To: root@chinstrap.cpqlinux.com
Subject: LogWatch for chinstrap.cpqlinux.com

 ################### LogWatch 6.0.1 (02/24/05) #################### 
        Processing Initiated: Fri Aug 26 04:02:10 2005
        Date Range Processed: yesterday
      Detail Level of Output: 10
              Type of Output: unformatted
           Logfiles for Host: chinstrap.cpqlinux.com
  ################################################################## 
 
 --------------------- Cron Begin ------------------------ 

 Commands Run:
    User root:
       run-parts /etc/cron.daily: 1 Time(s)
       run-parts /etc/cron.hourly: 24 Time(s)
 
 ---------------------- Cron End ------------------------- 

 
 --------------------- Kernel Begin ------------------------ 

 egrep: module: No such file or directory
 
 ---------------------- Kernel End ------------------------- 
<snip>

Version-Release number of selected component (if applicable):
logwatch-6.0.1-2.noarch.rpm

How reproducible:
Always

Steps to Reproduce:
1. Fresh install of FC4
2. Wait for daily run of logwatch or run manually: /etc/cron.daily/00-logwatch
3. Review mail generated to the root account
  

Actual Results:  The following section shows in the generated email:

 --------------------- Kernel Begin ------------------------ 

 egrep: module: No such file or directory
 
 ---------------------- Kernel End ------------------------- 

Expected Results:  Kernel entries, if any, should display in the kernel section.  Error message indicates a script problem.

Additional info:

I modified /etc/log.d/conf/services/kernel.conf from:

*Remove = locate module

to

*Remove = locate
*Remove = module

The error message went away and I also received my kernel: smb error message:

 --------------------- Kernel Begin ------------------------ 

 
 2 Time(s): SMB connection re-established (-5)
 
 ---------------------- Kernel End ------------------------- 

Also my listing from /var/log/messages:

[root@chinstrap ~]# cat /var/log/messages | grep kernel
Aug 22 04:02:17 chinstrap kernel: SMB connection re-established (-5)
Aug 23 04:02:16 chinstrap kernel: SMB connection re-established (-5)
Aug 24 04:02:16 chinstrap kernel: SMB connection re-established (-5)
Aug 25 04:02:16 chinstrap kernel: SMB connection re-established (-5)
Aug 25 14:27:01 chinstrap kernel: SMB connection re-established (-5)
Aug 26 04:02:18 chinstrap kernel: SMB connection re-established (-5)
Aug 26 10:33:19 chinstrap kernel: SMB connection re-established (-5)
[root@chinstrap ~]#
Comment 1 Ivana Varekova 2005-08-29 04:40:16 EDT
Thank you for your notice.
This bug (it is duplicate of 162947) is fixed in the last version -
logwatch-6.1.2-1.fc4. 
Ivana Varekova


*** This bug has been marked as a duplicate of 162947 ***

Note You need to log in before you can comment on or make changes to this bug.