Bug 166865 - quorum is not visible
quorum is not visible
Status: CLOSED NOTABUG
Product: Red Hat Cluster Suite
Classification: Red Hat
Component: clumanager (Show other bugs)
3
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Lon Hohberger
Cluster QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-26 11:49 EDT by Antonio Dolcetta
Modified: 2009-04-16 16:18 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-23 14:05:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Antonio Dolcetta 2005-08-26 11:49:03 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050614 Firefox/1.0.4

Description of problem:
2 node cluster loses quorum visibility

sometimes out cluster looses quorum visibility on one node after reboot
usually we are forced to use shutil -i on the affected node to fix.

in this case on one node we have:

[root@svxb1p063p root]# dd if=/dev/raw/raw1 of=/palla
dd: reading `/dev/raw/raw1': No such device or address
0+0 records in
0+0 records out
[root@svxb1p063p root]# dd if=/dev/sda1 of=/palla
0+0 records in
0+0 records out
[root@svxb1p063p root]# dd if=/dev/sda of=/palla
102400+0 records in
102400+0 records out
[root@svxb1p063p root]# cat /etc/sysconfig/rawdevices 
# raw device bindings
# format:  <rawdev> <major> <minor>
#          <rawdev> <blockdev>
# example: /dev/raw/raw1 /dev/sda1
#          /dev/raw/raw2 8 5
/dev/raw/raw1 /dev/sda1
/dev/raw/raw2 /dev/sda2

on the other node everything works correctly
[root@svxb1p064p root]# dd if=/dev/raw/raw1 of=/palla
dd: reading `/dev/raw/raw1': No such device or address
51168+0 records in
51168+0 records out
[root@svxb1p064p root]# dd if=/dev/sda1 of=/palla
51168+0 records in
51168+0 records out
[root@svxb1p064p root]# 

on the first node the cluster cannot see the quorum device

 

Version-Release number of selected component (if applicable):
redhat-config-cluster-1.0.3-1
clumanager-1.2.22-2

How reproducible:
Couldn't Reproduce

Steps to Reproduce:
probably happens when there is an interruption on the fc visibility

Additional info:
Comment 1 Lon Hohberger 2006-01-23 14:05:12 EST
Running 'shutil -i' has no direct affect on the FC connectivity (all it does is
open /dev/raw/*, same as the 'dd' command, and issue some writes).  Running
'shutil -i' should never be done if one of the cluster members is running.

An interruption in the FC or SCSI layer would definitely cause this, and is not
a clumanager bug.

Another thing which would cause this is having 'rawdevices' chkconfig'd off or
unmapped while the node is running.  Rerun 'chkconfig --level 2345 rawdevices
on' and make sure they are started.  You can verify this with 'raw -qa' or
'service rawdevices status'; looking at /etc/sysconfig/rawdevices displays
expected state, not current state.

e.g.

[root@yellow root]# raw -qa
/dev/raw/raw1:  bound to major 8, minor 49
/dev/raw/raw2:  bound to major 8, minor 50
[root@yellow root]# service rawdevices status
/dev/raw/raw1:  bound to major 8, minor 49
/dev/raw/raw2:  bound to major 8, minor 50


Note You need to log in before you can comment on or make changes to this bug.