Bug 166869 - wrong depences in the RPM-Provides
wrong depences in the RPM-Provides
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: boost (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Benjamin Kosnik
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-26 12:24 EDT by Oliver Seidel
Modified: 2013-08-09 01:47 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-13 06:15:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Oliver Seidel 2005-08-26 12:24:04 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.4; Linux) KHTML/3.4.2 (like Gecko)

Description of problem:
The RPM-Package don't provides the lib "libboost_python.so.1" but this lib is 
need by kdeedu (kdeedu-3.4.2-0.fc4.2). 
$ rpm -qp --provides boost-1.33.0-3.fc4.i386.rpm 
libboost_date_time.so.2 
libboost_filesystem.so.2 
libboost_iostreams.so.2 
libboost_prg_exec_monitor.so.2 
libboost_program_options.so.2 
libboost_python.so.2 
libboost_regex.so.2 
libboost_serialization.so.2 
libboost_signals.so.2 
libboost_test_exec_monitor.so.2 
libboost_thread.so.2 
libboost_unit_test_framework.so.2 
libboost_wserialization.so.2 
boost = 1.33.0-3.fc4 
 
rpm -q -requires kdeedu 
.... 
libboost_python.so.1 
..... 
 
 
 

Version-Release number of selected component (if applicable):
boost-1.33.0-3.fc4.i386.rpm

How reproducible:
Always

Steps to Reproduce:
1. rpm -Uvf boost-1.33.0-3.fc4.i386.rpm 
 

Actual Results:  ERROR: Failed dependencies: 
   libboost_python.so.1 is needed by (installed) kdeedu-3.4.2-0.fc4.2.i386 
   boost = 1.32.0-6.fc3 is needed by (installed) boost-devel-1.32.0-6.fc3.i386 
 

Additional info:
Comment 1 Benjamin Kosnik 2005-09-06 15:22:19 EDT
Note this only happens with the boost-1.33.0 rpms, which are in testing and have
not been pushed to updates.

To work around this, you can just use the boost-1.32.0 rpms, which are available
from the usual yum repositories.

The packaging of boost-1.33.0 is a bit contentious, but it looks likely that
fc-4 will not break the boost ABI, and thus continue to use boost-1.32.0.

-benjamin

Note You need to log in before you can comment on or make changes to this bug.