Bug 166886 - avc denied messages for dhcp and selinux_config_t
avc denied messages for dhcp and selinux_config_t
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: selinux-policy-targeted (Show other bugs)
4
All Linux
medium Severity low
: ---
: ---
Assigned To: Daniel Walsh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-26 15:42 EDT by Orion Poplawski
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-29 09:58:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Orion Poplawski 2005-08-26 15:42:45 EDT
Description of problem:
See the following in the logs:

Aug 26 12:46:05 makani kernel: audit(1125081961.939:2): avc:  denied  { read }
for  pid=2057 comm="cp" name="config" dev=hda5 ino=899015
scontext=system_u:system_r:dhcpc_t tcontext=root:object_r:selinux_config_t
tclass=file
Aug 26 12:46:05 makani kernel: audit(1125081961.939:3): avc:  denied  { getattr
} for  pid=2057 comm="cp" name="config" dev=hda5 ino=899015
scontext=system_u:system_r:dhcpc_t tcontext=root:object_r:selinux_config_t
tclass=file
Aug 26 12:59:04 makani kernel: audit(1125082741.945:2): avc:  denied  { read }
for  pid=2057 comm="cp" name="config" dev=hda5 ino=899015
scontext=system_u:system_r:dhcpc_t tcontext=root:object_r:selinux_config_t
tclass=file
Aug 26 12:59:04 makani kernel: audit(1125082741.945:3): avc:  denied  { getattr
} for  pid=2057 comm="cp" name="config" dev=hda5 ino=899015
scontext=system_u:system_r:dhcpc_t tcontext=root:object_r:selinux_config_t
tclass=file
Aug 26 13:02:38 makani kernel: audit(1125082954.973:2): avc:  denied  { read }
for  pid=2057 comm="cp" name="config" dev=hda5 ino=899015
scontext=system_u:system_r:dhcpc_t tcontext=root:object_r:selinux_config_t
tclass=file
Aug 26 13:02:38 makani kernel: audit(1125082954.973:3): avc:  denied  { getattr
} for  pid=2057 comm="cp" name="config" dev=hda5 ino=899015
scontext=system_u:system_r:dhcpc_t tcontext=root:object_r:selinux_config_t
tclass=file

Does not appear to prevent anything from working though.

Version-Release number of selected component (if applicable):
selinux-policy-targeted-1.25.3-12

How reproducible:
Every boot.
Comment 1 Daniel Walsh 2005-08-29 09:58:28 EDT
THis is because you are booting in permissive mode.   These AVC messages would
be blocked in enforcing mode.  Please run in enforcing mode and report avc
messages that you see there.

Note You need to log in before you can comment on or make changes to this bug.