Bug 166922 - monotone needs rebuild with new boost libraries
monotone needs rebuild with new boost libraries
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: monotone (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Roland McGrath
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-27 17:34 EDT by Alexandre Oliva
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-28 10:13:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexandre Oliva 2005-08-27 17:34:56 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.8b3) Gecko/20050818 Fedora/1.1-0.2.7.deerpark.alpha2.1 Firefox/1.0+

Description of problem:
The latest monotone build for the development tree requires libraries no longer present in the boost packages.  It needs a rebuild.

The same will hold true as soon as the ABI-breaking boost libraries currently in updates-testing for FC4 goes live.

Version-Release number of selected component (if applicable):
monotone-0.21-3.fc5

How reproducible:
Always

Steps to Reproduce:
1.yum install monotone
2.yum update

Actual Results:  Either monotone will fail to install because the newer boost is installed, or the update will fail because boost can't be updated.

Expected Results:  monotone in development extras should work with boost as in the development tree.

Additional info:
Comment 1 Roland McGrath 2005-08-27 18:59:52 EDT
The initial 0.22 build got botched by buildsystem bugs and didn't get into the
repository.  I resubmitted the build and it's waiting to be signed/pushed now.
Comment 2 Alexandre Oliva 2005-08-29 10:51:26 EDT
Ok, fixed for devel, will still need some action when the boost update in FC4
testing hits updates-released.
Comment 3 Alexandre Oliva 2005-10-28 10:13:21 EDT
bkoz says the update in testing will never be officially released, so people
tracking updates-testing are going to have to take manual action to get rid of
this error.  Oh well...

Note You need to log in before you can comment on or make changes to this bug.