Bug 166982 - Warning about underquoted definition of XIPH_PATH_AO in /usr/share/aclocal/ao.m4
Warning about underquoted definition of XIPH_PATH_AO in /usr/share/aclocal/ao.m4
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: libao (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: John (J5) Palmieri
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-29 08:36 EDT by Albert Strasheim
Modified: 2013-03-13 00:48 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-29 13:17:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to remove automake warning (325 bytes, patch)
2005-09-26 15:44 EDT, Denis Leroy
no flags Details | Diff

  None (edit)
Description Albert Strasheim 2005-08-29 08:36:11 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.7.7) Gecko/20050414 Firefox/1.0.3

Description of problem:
When I run an autogen.sh script I get the following warning:

/usr/share/aclocal/ao.m4:9: warning: underquoted definition of XIPH_PATH_AO

Version-Release number of selected component (if applicable):
libao-devel-0.8.5-3

How reproducible:
Always

Steps to Reproduce:
1. autogen.sh
2.
3.
  

Actual Results:  Warning about underquoted definition of XIPH_PATH_AO in /usr/share/aclocal/ao.m4.

Expected Results:  No warning.

Additional info:
Comment 1 John (J5) Palmieri 2005-08-29 13:17:05 EDT
Thanks for the report.  This is just auto-foo sillyness, it poses no problems
and is not a bug.
Comment 2 Albert Strasheim 2005-08-29 16:20:25 EDT
I submitted a similiar bug against aqhbci (bug 166981) and that was marked as  a
FC5Target bug.
Comment 3 Denis Leroy 2005-09-26 15:44:19 EDT
Created attachment 119270 [details]
Patch to remove automake warning
Comment 4 Denis Leroy 2005-09-26 15:45:08 EDT
Please reopen. It is a simple patch (see attached) and most other projects have
already moved to the stricter automake format. Also, the automake people might
very well decide to one day turn this warning into an error. There's no reason
libao should be the only package left to still have that warning.
Comment 5 John (J5) Palmieri 2005-09-26 16:21:48 EDT
Shouldn't this go upstream?
Comment 6 Albert Strasheim 2005-10-18 10:32:04 EDT
Did the patch go upstream? Anyone?

Note You need to log in before you can comment on or make changes to this bug.