Bug 166991 - At least one group can not be created with 'groupadd'
Summary: At least one group can not be created with 'groupadd'
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: shadow-utils   
(Show other bugs)
Version: 3.0
Hardware: All Linux
medium
low
Target Milestone: ---
Assignee: Peter Vrabec
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-08-29 14:52 UTC by Michael Quick
Modified: 2007-11-30 22:07 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-22 10:23:44 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Michael Quick 2005-08-29 14:52:18 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040113

Description of problem:
Seemingly a very minor issue, when trying to create the group "nappo" with "/usr/sbin/groupadd", it states it already exists when it obviously does not. RHEL3 tested on x86_64 and i686. 



SUCCESS:
shadow-utils-4.0.3-20.05
shadow-utils-4.0.3-22.02


FAILS:
shadow-utils-4.0.3-23.08 


Version-Release number of selected component (if applicable):
shadow-utils-4.0.3-23.08

How reproducible:
Always

Steps to Reproduce:
1. /usr/sbin/groupadd nappo

  

Actual Results:  [root@redcat root]# groupadd nappo
groupadd: group nappo exists
[root@redcat root]# cat /etc/group | grep nappo
[root@redcat root]#


Expected Results:  should create the group "nappo" and be seen in /etc/group.

Additional info:

Comment 1 Tim Waugh 2005-09-05 14:55:26 UTC
Fixing component and reassigning.

Comment 2 Peter Vrabec 2005-09-06 07:36:56 UTC
I can't reproduce it.

# uname -a
Linux vepro.redhat.usu 2.6.9-11.ELsmp #1 SMP Fri May 20 18:25:30 EDT 2005 x86_64
x86_64 x86_64 GNU/Linux
# rpm -q redhat-release
redhat-release-3AS-13.5.1
# rpm -q shadow-utils
shadow-utils-4.0.3-23.08
# cat /etc/group | grep nappo
# /usr/sbin/groupadd nappo
# cat /etc/group | grep nappo
nappo:x:508:



Note You need to log in before you can comment on or make changes to this bug.