Bug 167021 - up2date can be updated without up2date-gnome, causes dependency issues
Summary: up2date can be updated without up2date-gnome, causes dependency issues
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: up2date (Show other bugs)
(Show other bugs)
Version: 3.0
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Adrian Likins
QA Contact: Beth Nackashi
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-08-29 16:30 UTC by Beth Nackashi
Modified: 2007-11-30 22:07 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-29 17:44:08 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Beth Nackashi 2005-08-29 16:30:21 UTC
Description of problem:
The up2date package can be updated without removing or updating up2date-gnome. 
This causes dependency issues when installing new packages.  But, beyond the
dependency issues, this is just bad.

Version-Release number of selected component (if applicable):
up2date-4.2.57 upgrading to up2date-4.4.44

How reproducible:
always

Steps to Reproduce:
1.  install up2date-4.2.57 and up2date-gnome-4.2.57 (this can be accomplished by
kickstarting a box to RHEL 3 U5)
2.  get the latest up2date (4.4.44)
3.  rpm -Uvh up2date-4.4.44-3.xxxx.rpm
  
Actual results:
up2date will install over existing up2date-4.2.57 without outputting a
dependency error for up2date-gnome.  Also, up2date-gnome-4.2.57 disappears.

[root@dhcp223 tmp]# rpm -qa|grep up2date
up2date-4.4.44-3


Expected results:
rpm -Uvh outputs a dependency error for up2date-gnome, forcing the user to
either update up2date-gnome or remove up2date-gnome.

Additional info:
This causes dependency errors when trying to install other packages such as
rhn-apache:

D: Checking for dependencies
D: RPM returned 2 deps.
D: Processing dependency (('pyorbit', '1.99.3', '5'), ('libIDL', '0.7.1'), 12,
None, 0)
D: Processing dependency (('up2date-gnome', '4.2.57', '2'), ('up2date',
'4.2.57'), 8, None, 0)
D: Dependencies: [('pyorbit', 'libIDL'), ('up2date-gnome', 'up2date')]
D: Dep ['libIDL', 'up2date'] Fetched via: [['libIDL', '0.8.0', '9', '', 'i386',
'79915', 'rhel-i386-as-3']]
D: Got back response: [['libIDL', '0.8.0', '9', '', 'i386', '79915',
'rhel-i386-as-3']]
D: Candidates for the selected list: [['libIDL', '0.8.0', '9', '', 'i386',
'79915', 'rhel-i386-as-3']]
D: Adding to transaction set ['libIDL', '0.8.0', '9', '', 'i386', '79915',
'rhel-i386-as-3']
D: Checking for dependencies
D: RPM returned 1 deps.
D: Processing dependency (('up2date-gnome', '4.2.57', '2'), ('up2date',
'4.2.57'), 8, None, 0)
D: Dependencies: [('up2date-gnome', 'up2date')]
D: Got back response: []
D: Package up2date-gnome raised invalid dependency. Adding [['up2date-gnome',
'4.2.57', '2', '', 'i386', '141523', 'rhel-i386-as-3']] to set
D: Candidates for the selected list: []
D: Package up2date-gnome raised invalid dependency. Adding ['up2date-gnome',
'4.2.57', '2', '', 'i386', '141523', 'rhel-i386-as-3'] to set
D: Candidates for the selected list: [['up2date-gnome', '4.2.57', '2', '',
'i386', '141523', 'rhel-i386-as-3']]
D: Sending back response (18, 'Failed: packages requested raised dependency
problems', {'failed_deps': ((('up2date-gnome', '4.2.57', '2'), ('up2date',
'4.2.57'), 8, '', 0),), 'version': '0', 'name': 'packages.update.failed_deps'})
D: do_call packages.checkNeedUpdate ('rhnsd=1',)
D: local action status:  (0, 'rpm database not modified since last update (or
package list recently updated)', {})
[root@dhcp223 root]# rpm -qa|grep up2date
up2date-4.4.44-3
[root@dhcp223 root]# rpm -q up2date-gnome
package up2date-gnome is not installed

Comment 1 Beth Nackashi 2005-08-29 17:44:08 UTC
I think I was on crack when I wrote this.


Note You need to log in before you can comment on or make changes to this bug.