Bug 167077 - gquilt fails to start on Fedora Core 3
gquilt fails to start on Fedora Core 3
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gquilt (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Josh Boyer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-29 20:43 EDT by Josh Boyer
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: gquilt-0_13-2_fc3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-30 12:36:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to use gtk+ 2.4 stock items (8.95 KB, patch)
2005-08-30 12:35 EDT, Josh Boyer
no flags Details | Diff

  None (edit)
Description Josh Boyer 2005-08-29 20:43:45 EDT
Description of problem:

gquilt fails to start

Version-Release number of selected component (if applicable):

gquilt.noarch 0:0.13-1.fc3

How reproducible:

Always

Steps to Reproduce:
1. run gquilt
2.
3.
  
Actual results:

gquilt fails to start with the following traceback

Traceback (most recent call last):
  File "/usr/share/gquilt/gquilt.py", line 697, in ?
    app = gquilt()
  File "/usr/share/gquilt/gquilt.py", line 391, in __init__
    hpane_outer.add1(self._create_playground_file_tree())
  File "/usr/share/gquilt/gquilt.py", line 343, in _create_playground_file_tree
    self.playground_files.append_selection_menu_item("_Edit", "Edit the selected
files after adding them to the top patch", gtk.STOCK_EDIT,
self._edit_playground_selection_in_top_patch)
AttributeError: 'module' object has no attribute 'STOCK_EDIT'


Expected results:

gquilt starts

Additional info:

More info when I dig into this
Comment 1 Josh Boyer 2005-08-29 20:47:21 EDT
Seems to be an incompatibility with the version of pygtk2 that is provided by
FC-3.  The gtk.STOCK_EDIT item wasn't added until pygtk 2.6.
Comment 2 Josh Boyer 2005-08-30 12:35:57 EDT
Created attachment 118256 [details]
Patch to use gtk+ 2.4 stock items

Fixed up now with this patch

Note You need to log in before you can comment on or make changes to this bug.